Closed Bug 1471810 Opened 2 years ago Closed 2 years ago

[wpt-sync] Sync PR 11703 - [LayoutNG] bugfix for NG painting in vertical-rl with scrollbars.

Categories

(Core :: CSS Parsing and Computation, enhancement, P4)

enhancement

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 11703 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/11703
Details from upstream follow.

Aleks Totic <atotic@chromium.org> wrote:
>  [LayoutNG] bugfix for NG painting in vertical-rl with scrollbars.
>  
>  This bug occurs when painting NG child inside non-inline vertical-rl parent
>  with scrollbars.
>  
>  Root cause is extra scrollbar offset that Paint applies to Legacy painting that
>  is not needed for NG.
>  
>  The fix is hacky: NG applies reverse offset.
>  
>  This fix does not make any additional tests pass or fail.
>  
>  Bug: 852395
>  Cq-Include-Trybots: luci.chromium.try:linux_layout_tests_layout_ng
>  Change-Id: I7dda2cdbf682485ab30c048987ae683981731886
>  Reviewed-on: https://chromium-review.googlesource.com/1115863
>  WPT-Export-Revision: bd190ee6ac6fa0bf88cae538bc0881ff9fcb0eac
Component: web-platform-tests → CSS Parsing and Computation
Product: Testing → Core
Ran 1 tests
PASS   : 1
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7cc70b15cd33
[wpt PR 11703] - [LayoutNG] bugfix for NG painting in vertical-rl with scrollbars., a=testonly
https://hg.mozilla.org/mozilla-central/rev/7cc70b15cd33
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.