JavaScript doesn't run in ynet.co.il

VERIFIED DUPLICATE of bug 133214

Status

Tech Evangelism Graveyard
Hebrew
--
major
VERIFIED DUPLICATE of bug 133214
16 years ago
3 years ago

People

(Reporter: rn23, Assigned: Katsuhiko Momoi)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
Rolling JavaScript in ynet.co.il on top right, just under the banner, isn't shown.
Compare with IE {4|5|5.5|6} or Netscape {4.*}.
(Reporter)

Comment 1

16 years ago
Build=1.0 RC 3

Comment 2

16 years ago
Can't see where this comes from exactly, but site uses many document.all
As this is a Tech Evangelism, it might be either dupe of bug 122565 or depend on
it ?
(Reporter)

Comment 3

16 years ago
I understand what 122565 is about. Although it's the same page, I am not sure 
it's related. The problem there, is that messages are not opened when clicked. 
The forum page there holds all the message headers+text, but the text is 
hidden until clicked, and is shown using JS. The problem here, is that the 
whole application doesn't work. It might be related, but I guess it needs 
further investigation as for the actual cause.
As for me, the JS isn't write for Mozilla... Probably based on poor old dynduo.

Comment 5

16 years ago
The changing text at the top is not created by JavaScript;
it is a Shockwave Flash movie. I get this error in 

  Mozilla > Tools > Web Development > JavaScript Console:

Error: flashObj has no properties
Source File:
http://pbid.pro-market.net/engine?site=317+space=86+page='8'+size=68+position=m+
distinct+rnd=(2498811807105269779)+linktarget='_blank'
Line: 28


Amazingly, the Flash movie shows perfectly if we open the site
in the Mozilla DOM Inspector! Just try it:

    Tools > Web Development > DOM Inspector

(Assuming you have the Flash plug-in installed)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

16 years ago
Oops, you meant the scrolling text in the upper-right,
UNDER the banner ad; let me look at that now - 

Comment 7

16 years ago
The "missing" part of the page is an <iframe> which has this as a SRC:
http://www.ynet.co.il/Ext/Comp/Ticker/Dhtml_Ticker/0,10016,184,00.html

Load this in IE6 and it works fine (look to the right to see the text).
But it doesn't work in Mozilla. The reason: 

if (document.all)
{
  document.write('<marquee direction=up scrollAmount=1   
                   style=width:115;height:126><table

                        etc. etc.  

                 </marquee>')
}



I don't see any codepath for Mozilla; that's why nothing shows up
Reassigning to Tech Evangelism -
Assignee: rogerl → momoi
Component: JavaScript Engine → Middle Eastern
Product: Browser → Tech Evangelism
QA Contact: pschwartau → xslf
Version: other → unspecified

Comment 8

16 years ago

*** This bug has been marked as a duplicate of 133214 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
tech evang june 2003 reorg
Component: Middle Eastern → Hebrew
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.