Closed Bug 1471895 Opened Last year Closed Last year

Scrollbar overlays children with white-space:nowrap

Categories

(Core :: Layout: Block and Inline, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 764076
Tracking Status
firefox63 --- affected

People

(Reporter: mattcoz, Unassigned)

References

Details

Attachments

(1 file)

Attached file test.html
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180627120029

Steps to reproduce:

Inline-block div with a set height and overflow:auto and rows of flex divs with white-space:nowrap.

I've attached a simple test page showing the issue.


Actual results:

The scrollbar overlays the end of the text.


Expected results:

The inline-block div should be wide enough so that the full text is visible and the scrollbar does not overlay it. Chrome and Edge display it correctly.
Actually, it doesn't even have to be flex, just white-space:nowrap is all that is needed to cause the problem.
Summary: Scrollbar overlays flex children with white-space:nowrap → Scrollbar overlays children with white-space:nowrap
Found this duplicate from 6 YEARS AGO. https://bugzilla.mozilla.org/show_bug.cgi?id=764076

How has this not been addressed in all this time?
Maybe is a good idea to close this bug as duplicate of bug 764076, since that one contains a regression range.
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Block and Inline
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
See Also: → 764076
Version: 63 Branch → Trunk
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 764076
You need to log in before you can comment on or make changes to this bug.