Closed Bug 14719 Opened 21 years ago Closed 20 years ago

[PP] Win32- 'Save changes?' dialog has bad button labels

Categories

(Core :: DOM: Editor, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED WONTFIX

People

(Reporter: cpratt, Assigned: cmanske)

References

Details

Build ID: 1999092308
Platform: Windows NT (this bug is Windows-specific)

To reproduce:
- Launch apprunner
- Select File | New | Blank Window
- Type something into the window
- Select File | Close

Result: A dialog box comes up with three buttons:

Save | Cancel | Don't Save

Expected result: We should be seeing this:

Yes | No | Cancel

This is what you see in other common Windows apps such as Notepad and Front Page
Express.
Assignee: buster → cmanske
Target Milestone: M12
if this is trivial, it should go in for M12 for mail compose at least.  If it's
not trivial, please mark it M15.
From a user perspective it isn't trivial - the dialog is confusing in that the
wording is nonstandard and the button order is 'off' (often people are used to
moving their mouse to a certain position in the dialog to save or cancel... and
that could have bad repercussion).

btw, I made a mistake here: the dialog currently reads:

Save changes to current file?

and it should probably read:

The text in the * file has changed.
Do you want to save the changes?

(* represents the file name or "untitled" if it's a new blank file)

or perhaps:

Save changes to *?

(* is the TITLE of the HTML document, or 'new blank document', or what have you)

I think we need someone in UI to have a look at this... cc'ing shuang.
Status: NEW → ASSIGNED
Depends on: 14735
The button order problem is not under our control. I am working with David
Matiskella on that -- we need to be able to tell the dialog which location
the "cancel" action associates with (The "X" on the Windows dialog must link
to the same action as the "Cancel" button.) David: Any decisions on that issue?
If that is fixed for M12
Concerning the message text, that is easy to change. We used this in 4.x:
Do you want to save changes to:
[file URL on the next line]?
I can make this change for M12
Concerning the button text, the Mac prefers to show "action verbs" rather than
just "Yes" and "No", and since we don't have the solution to make
platform-specific changes to this text, I opted to use the Mac design. It's
clearer anyway and I don't think Window's users will mind to much!
Speaking for the vast majority of computer users (that is, Windows users), yes,
we mind very, very much. Please bear in mind that a successful UI is one that
blends in well with other applications on the platform; that was one of the
great strengths of the original Mac OS (all apps had a consistent look and
feel). The current wording of the dialog is strikingly different than all other
common Windows apps, and is therefore unfamiliar to perhaps 90% of our target
market. Given that, I'd like to see this change to the de facto standard:
Windows. As far as it being clearer, I understand your point and agree - but
familiar is IMHO more important than clear. shuang?
Fine. But make sure you do platform specific DTD's for the mac because no mac
user is going to use a product with a sucky UI that doesn't use the standard
terminology for a save/don't save/cancel dialog.
As far as I see, this is impossible via DTD and overlays.
We are in C++ code and want to put up a dialog with
[Yes] [No] [Cancel]
but on the Mac it is
[Don't Save] [Cance] [Save]
We are not using a DTD for the strings, we are getting strings from a string
bundle. So we would have to have use #ifdef to compile code to get the specific
strings for each platform.
I still don't see any platform-specific XUL overlays checked in to control the
order of buttons. The "Ok"/"Yes"/"Save" action is always the right-most button
on the Mac, correct?
Well platform specific string bundles work just as well. As far as platform
specific stuff look at platformDialogOverlay.xul
Summary: [PP] Win32- 'Save changes?' dialog has bad button labels, order → [PP] Win32- 'Save changes?' dialog has bad button labels
The "button order" part of this has been fixed.
We are consulting with our UE team to see if we want "Yes" "No" or
"Save" "Don't Save" for the button text in Windows and UNIX.
Hope German will give you an answer soon ( or he can have this bug instead...)
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
The consensus from newgroup discussion is to use the Mac style of "Save" and
"Don't Save", as long as buttons appear in the platform-specific location.
Nothing like imposing Mac standards on Windows users. :)

Marking verified wontfix.
Status: RESOLVED → VERIFIED
verified in 10/22 build.
Duplicate of this bug: 420597
You need to log in before you can comment on or make changes to this bug.