Unverified Firefox Account warning icon is distorted

VERIFIED FIXED in Firefox 62

Status

()

defect
VERIFIED FIXED
11 months ago
10 months ago

People

(Reporter: eoger, Assigned: markh)

Tracking

({regression})

unspecified
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 verified, firefox63 verified)

Details

Attachments

(2 attachments)

Reporter

Description

11 months ago
Posted image uh oh.png
This can be seen in about:preferences with an unverified FxA user (see screenshot).
Mark, this is fairly minor new regression from 62, but I could still take a patch for 62 beta if you find someone to fix it.
Flags: needinfo?(markh)
Comment on attachment 8991519 [details]
Bug 1471906 - ensure FxA error icons are centered to prevent distortion. r?eoger

Edouard Oger [:eoger] has approved the revision.

https://phabricator.services.mozilla.com/D2091
Attachment #8991519 - Flags: review+

Comment 4

11 months ago
Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/135c148a2aad
ensure FxA error icons are centered to prevent distortion. r=eoger
Assignee

Comment 5

11 months ago
Comment on attachment 8991519 [details]
Bug 1471906 - ensure FxA error icons are centered to prevent distortion. r?eoger

Approval Request Comment
[Feature/Bug causing the regression]: bug 1454231
[User impact if declined]: Ugly icons in about:preferences when creating or changing password for a firefox account
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Create a Firefox account but do not verify it. Before this patch about:preferences#sync will look like the attachment in this bug. After this patch the warning icon should be square.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: A 2 line layout-only patch
[String changes made/needed]: None
Flags: needinfo?(markh)
Attachment #8991519 - Flags: approval-mozilla-beta?

Comment 6

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/135c148a2aad
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 8991519 [details]
Bug 1471906 - ensure FxA error icons are centered to prevent distortion. r?eoger

Minor CSS fix to UI, let's uplift for beta 9.
Attachment #8991519 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee: nobody → markh
Managed to reproduce using Firefox 62.0b6 and 62.0a1 (2018-06-10).
Have checked with Firefox 63.0a1 (2018-07-30) and 62.0b12 on macOS 10.9, Ubuntu 16.04LTS, win 10x64 and can confirm the issue is no longer present on any platform.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.