Closed Bug 1472114 Opened Last year Closed Last year

Firefox Sync does not move my bookmarks

Categories

(Firefox :: Sync, defect)

63 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1474033
Tracking Status
firefox63 --- affected

People

(Reporter: Gioxx, Unassigned)

References

Details

Attachments

(2 files)

Attached file aboutsync-logfiles.zip
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180627222831

Steps to reproduce:

I saved two new bookmarks in my Firefox (Nightly) on office laptop, and I have moved them on respective folders.
I have also moved one old bookmark in a different folder (from bookmarks toolbar to a subfolder).


Actual results:

I went home, I turned on my MacBook (with Firefox Nightly) with the same account connected, this synchronized the bookmarks and I found the new bookmarks in the folder "other bookmarks" and the old bookmark still stopped in its original location. The same thing happened by opening Firefox on my office laptop the next day.


Expected results:

I expect that the new bookmarks remain in their respective folders on every Firefox used, and that the old bookmark moves to the new subfolder of my choice
Duplicate of this bug: 1472131
Can confirm this issue happens on the latest Nightly 63 build.
Syncing between a desktop profile and a mobile device (or 2 desktop profiles), the bookmarks are not moved on the synced device. Moving bookmarks into new folders from an Android device will sync correctly on the other profiles.
Status: UNCONFIRMED → NEW
Component: Untriaged → Sync
Ever confirmed: true
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1474033
you mean that every time I have to synchronize through a firefox android interface ?!! I think this issue is not yet resolved.
The patch in bug 1474033 should fix this bug. You can follow the other bug if you like, we'll get it landed and uplifted to Beta next week.
Work-around: export all bookmarks to json file, delete all bookmarks from Firefox Desktop, sync account (check -and wait for- on the second workstation / mobile phone if You loose all bookmarks), then import the exported json and sync again.
You need to log in before you can comment on or make changes to this bug.