Closed Bug 1472200 Opened Last year Closed Last month

Only the Rules panel is displayed if enabling 3-Pane Inspector while the right Inspector section is at minimum width

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox62 affected, firefox63 affected, firefox71 fixed)

RESOLVED FIXED
Firefox 71
Tracking Status
firefox62 --- affected
firefox63 --- affected
firefox71 --- fixed

People

(Reporter: mboldan, Assigned: miker)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: regressionwindow-wanted, Whiteboard: [dt-q])

Attachments

(4 files)

Attached image 3pane inspector.gif
[Affected versions]:
- Firefox 62.0b4, Firefox 63.0a1 (2018-06-28)

[Affected platforms]:
- Windows 10x64, macOS 10.12.6, Ubunutu 16.04x64

[Steps to reproduce]:
1. Launch Firefox.
2. Press F12 or Right Click and select Inspect Element.
3. Make sure that 3-Pane inspector is toggled off.
4. Grab the right section separator and drag all the way to right.
5. Toggle on 3-Pane inspector.

[Expected result]:
- All the sections are visible. 

[Actual result]:
- Only the Rules section is visible. See the attached screencast.

[Regression range]:
- I will search for a regression asap.

[Additional notes]:
- Note that the panel that containing 'Layout, Computed, Animations, Fonts' can be minimized until is not visible if dragging it to the right. Maybe this is the cause of the issue.
Assignee: nobody → gl
Status: NEW → ASSIGNED
Priority: -- → P3
Whiteboard: [dt-q]
Assignee: gl → nobody
Status: ASSIGNED → NEW
See Also: → 1516549
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Attached image Panel resize bug.gif

This turns out to be a bug with our resize code inside devtools/client/shared/components/splitter/SplitBox.js.

When we hit minWidth we need to take minWidth into account.

Attached image fixed.gif

A gif showing that this is fixed.

Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58b4283727ea
Only the Rules panel is displayed if enabling 3-Pane Inspector while the right Inspector section is at minimum width r=jlast
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
You need to log in before you can comment on or make changes to this bug.