Editing preferences makes about:welcome unresponsive

VERIFIED FIXED in Firefox 62

Status

()

defect
P1
normal
VERIFIED FIXED
11 months ago
10 months ago

People

(Reporter: ewright, Assigned: andreio)

Tracking

({regression})

62 Branch
Firefox 63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62+ fixed, firefox63 verified)

Details

User Story

https://github.com/mozilla/activity-stream/compare/79c5b431a35852d56ee52fc9044de896465e252b...firefox-62b7

Attachments

(2 attachments)

(Reporter)

Description

11 months ago
STR:

navigate to `about:welcome`
click 'skip this step'
click the gear in the right corner
on the new tab it opens click on a box to change a preference
switch back to the about:welcome tab
interact with a tile or link on the page

AR:
the tile is unclickable, and the mouse remains as an arrow instead of a pointer

ER:
You can click and interact with links and tiles
(Reporter)

Updated

11 months ago
Blocks: 1448918
It looks like the page also breaks when you reorder the sections, dismiss or follow the import flow, or acknowledge the Pocket disclaimer.
OS: Unspecified → All
Hardware: Unspecified → All
Build ID 	20180701220749
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Adding that the page becomes unresponsive after continuing/dismissing the sign-in if you simply collapse a section. It seems this behavior was always this way ever since we implemented the about:welcome page.
(Assignee)

Updated

11 months ago
Assignee: nobody → andrei.br92

Updated

11 months ago
Iteration: --- → 63.1 - July 9
Priority: -- → P1

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED

Updated

11 months ago
Blocks: 1473744

Comment 5

11 months ago
This probably wants to be uplifted to 62? If so, we'll want the appropriate flags set
Flags: needinfo?(ewright)
I have verified that the issue is no longer reproducible on the latest Nightly build (63.0a1, Build ID 20180708220048) on Windows 10 x64, Mac 10.13.6 and Arch Linux x64.
Status: RESOLVED → VERIFIED
Andrei, could you please fill the uplift request?
Thanks
Flags: needinfo?(andrei.br92)
Comment hidden (mozreview-request)
(Assignee)

Comment 9

10 months ago
Comment on attachment 8990691 [details]
Bug 1472209 - Remove StartupOverlay if the about:welcome tour is skipped.

Approval Request Comment
[Feature/Bug causing the regression]: The new about:welcome page
[User impact if declined]: Activity Stream will be unresponsive for users when they navigate from about:welcome
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Already verified 
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: small uplift that has been verified
[String changes made/needed]: n/a
Flags: needinfo?(ewright)
Flags: needinfo?(andrei.br92)
Attachment #8990691 - Flags: approval-mozilla-beta?

Comment 10

10 months ago
mozreview-review
Comment on attachment 8990691 [details]
Bug 1472209 - Remove StartupOverlay if the about:welcome tour is skipped.

https://reviewboard.mozilla.org/r/255776/#review262522

Previously reviewed on github, carrying the r+ here
Attachment #8990691 - Flags: review?(usarracini) → review+

Comment 11

10 months ago
https://hg.mozilla.org/mozilla-central/rev/c8abaff6bcae
Target Milestone: --- → Firefox 63
Comment on attachment 8990691 [details]
Bug 1472209 - Remove StartupOverlay if the about:welcome tour is skipped.

Verified in nightly, fix for regression in new about page.
Attachment #8990691 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Trying to import the mozreview patch on top of beta causes conflicts for install.rdf.in and the bundle file. Might be because bug 1472297 and bug 1470170 landed there. Please provide a patch which applies on beta.
Flags: needinfo?(andrei.br92)

Comment 14

10 months ago
andreio, this needs to land on our firefox-62 git branch first to generate the appropriate patch file.
Comment hidden (mozreview-request)
(Assignee)

Updated

10 months ago
Flags: needinfo?(andrei.br92)

Updated

10 months ago
User Story: (updated)
Depends on: 1470170

Updated

10 months ago
Blocks: 1474244
You need to log in before you can comment on or make changes to this bug.