Closed Bug 1472216 Opened Last year Closed Last year

The Search Bar doesn't work after skipping/completing the about:welcome sign in

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.1 - July 9
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 + verified
firefox63 + verified

People

(Reporter: cmuresan, Assigned: ursula)

References

Details

(Keywords: regression)

Attachments

(2 files)

[Affected versions]:
- Nightly 63.0a1, Build ID 20180629100106
- Firefox Beta v62.0b3, Build ID 20180625141512

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Steps to reproduce]:
1. Open the browser and navigate to the about:welcome page.
2. Click the "Skip this step" button.
3. Observe the New Tab's Search Bar.
4. Make a search and observe the behavior.

[Expected results]:
- Step 3: The Search Bar's background is white and the Search engine icon is displayed before the "Search the web" string.
- Step 4: The term is searched using the default search engine.

[Actual results]:
- Step 3: The Search Bar's background is the same as the page's, making it look disabled, and the Search engine icon is not displayed at all.
- Step 4: Nothing happens.

[Notes]:
- The onboarding notification is also missing from the New Tab page.
- The issue is no longer reproducible on a newly opened tab.
- Attached a screen recording of the issue.
Any idea why this would be happening? It's pretty bad. After you try using the search box, the whole newtab seems to freeze and become unresponsive. It corrects itself after you open a new tab, but that's not a great experience for the first new tab you'll encounter with Firefox
Flags: needinfo?(ewright)
Probably related to content search not allowing messages from about:welcome:

https://searchfox.org/mozilla-central/source/browser/base/content/tab-content.js#229-231
(In reply to Ed Lee :Mardak from comment #2)
> Probably related to content search not allowing messages from about:welcome:
> 
> https://searchfox.org/mozilla-central/source/browser/base/content/tab-
> content.js#229-231

I tried it, yes that is exactly it!
Flags: needinfo?(ewright)
Some reason I seem to recall content search code having custom search identifiers if it's on about:newtab vs about:home. I guess it might not be important to differentiate that it's actually about:home, but which one does it end up using…
(In reply to Ed Lee :Mardak from comment #4)
> Some reason I seem to recall content search code having custom search
> identifiers if it's on about:newtab vs about:home. I guess it might not be
> important to differentiate that it's actually about:home, but which one does
> it end up using…

how would one find what the custom search identifiers are?
https://github.com/mozilla/activity-stream/blame/master/content-src/components/Search/Search.jsx#L34

Looks like the code checks for about:newtab, so about:welcome is treated the same as about:home.
(In reply to Ed Lee :Mardak from comment #7)
> https://github.com/mozilla/activity-stream/blame/master/content-src/
> components/Search/Search.jsx#L34
> 
> Looks like the code checks for about:newtab, so about:welcome is treated the
> same as about:home.

Do you think that's acceptable, or should it have it's own identifier?
The identifier as about:home is fine
Comment on attachment 8988875 [details]
Bug 1472216 - in content search is allowed on about:welcome.

https://reviewboard.mozilla.org/r/254036/#review260782

R+ on a green try. Thanks!
Attachment #8988875 - Flags: review?(usarracini) → review+
Important to not break the search bar. :) Tracking for 62 and 63. 
Asking for verification from QA, also.
Flags: qe-verify+
Pushed by usarracini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/62da3d173f63
in content search is allowed on about:welcome. r=ursula
Assignee: nobody → usarracini
Iteration: --- → 63.1 - July 9
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/62da3d173f63
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
I have reproduced this bug with Nightly 63.0a1 (2018-06-29) on Windows 10, 64 Bit!
This bug's fix is verified with latest Nightly!

Build ID 	20180704100142
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
QA Whiteboard: [bugday-20180704]
Comment on attachment 8988875 [details]
Bug 1472216 - in content search is allowed on about:welcome.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1448918
[User impact if declined]: Search will be broken on the first newtab for first-run users in Firefox 62
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes 63.0a1 (2018-06-29)
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Adding about:welcome to a white list, no code logic changing
[String changes made/needed]: None
Attachment #8988875 - Flags: approval-mozilla-beta?
I have verified that the issue is no longer reproducible on the latest Nightly build (63.0a1, 20180705012031) on Windows 10 x64, Mac 10.13.5 and Arch Linux x64. 
Based on this and comment 16 I will mark the issue as Verified-Fixed.
Status: RESOLVED → VERIFIED
Comment on attachment 8988875 [details]
Bug 1472216 - in content search is allowed on about:welcome.

Fix for regression in 62, verified in nightly, let's uplift for beta 7.
Attachment #8988875 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I have verified that the issue is no longer reproducible on the latest Beta built (62.0b7, Build ID 20180709172241) on Windows 10 x64, Mac 10.13.6 and Arch Linux x64.
Flags: qe-verify+
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.