Closed Bug 1472229 Opened 2 years ago Closed 5 months ago

Categories

(Developer Documentation Graveyard :: General, enhancement)

All
Other
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dheiberg, Unassigned)

References

()

Details

:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

The en-GB variant of the Network Monitor page leads to 404. The en-US variant is still alive, so redirect would make sense?
Flags: needinfo?(cmills)
Generally we only write en-US pages; we never write a separate en-GB variant. It doesn't look like this page exists; did you see a red link pointing to it somewhere, or something like that?
Flags: needinfo?(cmills) → needinfo?(dheiberg)
(In reply to Chris Mills (Mozilla, MDN editor) [:cmills] from comment #1)
> Generally we only write en-US pages; we never write a separate en-GB
> variant. It doesn't look like this page exists; did you see a red link
> pointing to it somewhere, or something like that?

I came across the en-GB link on www.google.co.uk, it was the first hit when searching for the Network Monitor documentation
To be more specific, when I search for 'firefox see raw request' on google (.com and .co.uk), this en-GB link is the first hit. https://screenshots.firefox.com/CBY8L68yqGDtKEvE/www.google.com
Flags: needinfo?(dheiberg) → needinfo?(cmills)
This is strange. I'm NI'ing john from our MDN platform team to see if he can shed any light on this.
Flags: needinfo?(cmills) → needinfo?(jwhitlock)
That is strange. Google's webmaster tools doesn't show any external links to that page, which may mean it is an in-product link, or that Google doesn't bother keeping track of linkers to 404s.

The most likely candidate was the Network Monitor tool itself, but it appears to be using the locale-less links, like it should:

https://github.com/mozilla/gecko/blob/2e01747945ae559316e74c8ac059c90184700330/devtools/client/netmonitor/src/utils/mdn-utils.js#L189-L196

We're tracking 404s in GA, and there are these slugs under en-GB:

/
/?utm_source=mozilla&utm_medium=firefox-tile&utm_campaign=default
/Add-ons/WebExtensions/API/cookies/remove
/asdfasdf
/developers/addon/submit/wizard-listed
/docs/Tools
/docs/Tools/Network_Monitor
/docs/Tools/Network_Monitor#Network_request_details
/docs/Tools/Network_Monitor#Network_request_list
/docs/Tools/Network_Monitor#Opening_the_Network_Monitor
/docs/Tools/Network_Monitor#Pausing_and_resume_network_traffic_recording
/docs/Tools/Network_Monitor#Throttling
/docs/Web
/docs/Web/API/Canvas_API
/docs/Web/API/Document/createTextNode
/docs/Web/API/Element/insertAdjacentHTML#Browser_Compatibility
/docs/Web/API/File/File
/docs/Web/API/History_API
/docs/Web/API/Response
/docs/Web/API/WebGLRenderingContext/vertexAttribPointer
/docs/Web/API/Window/devicePixelRatio
/docs/Web/CSS/box-shadow
/docs/Web/CSS/font-weight
/docs/Web/CSS/grid
/docs/Web/Events
/docs/Web/HTML/Element/%D0%BA%D0%BD%D0%BE%D0%BF%D0%BA%D0%B0
/docs/Web/HTML/Element/caption
/docs/Web/HTML/Element/input/date
/docs/Web/HTML/Supported_media_formats
/docs/Web/HTTP/Caching_FAQ
/docs/Web/HTTP/Headers/accept
/docs/Web/HTTP/Status
/docs/Web/HTTP/Status/404
/docs/Web/JavaScript
/docs/Web/JavaScript/New_in_JavaScript/ECMAScript_2015_support_in_Mozilla
/docs/Web/JavaScript/Reference/Global_Objects
/docs/Web/JavaScript/Reference/Global_Objects/Array/map
/docs/Web/JavaScript/Reference/Global_Objects/Array/slice
/docs/Web/JavaScript/Reference/Global_Objects/Object
/docs/Web/JavaScript/Reference/Global_Objects/String/TrimRight
/docs/Web/JavaScript/Reference/Klassen
/docs/Web/JavaScript/Reference/Operators/delete
/docs/Web/JavaScript/Reference/Statements/for...of
/docs/Web/JavaScript/Reference/Statements/let
/docs/Web/JavaScript/Reference/Statements/let
/docs/Web/JavaScript/Referencia/Objetos_globales/String/search
/docs/Web/Javascript/Reference
/docs/Web/Manifest
/docs/Web/SVG
/docs/Web/SVG/Attribute/stroke-linejoin

I found this link in some Python, but it seems unlikely this is the source:

https://github.com/mozilla/splice/blob/96a6212a359223094e8ade2e7a27398226a52aae/scripts/index_walker.py#L108

In May 2018, we changed the locale-handling backend, so it is possible this was a redirect or displayed content before then.

So, I'm stumped on the root cause, and I'm not sure how Google found that link. I've requested that the URL should be removed from the index.
rraue: Any idea how this page ended up in the google.co.uk index, and best ways to get it out?
Flags: needinfo?(jwhitlock) → needinfo?(rraue)
I found a external link to the page via ahref.com and this explains why it got indexed in the first place: http://www.itgo.me/a/7438878384400316965/return-json-from-php-to-ajax. But it doesn't explain, why Google indexed and holds a 404 for so long in the index and doesnt replace it with the en-US version. Are you sure that this version was never live?

As well the info command shows the right page and it should be displayed in search as well: https://www.google.com/search?client=firefox-b-ab&ei=s3Y8W9_LNYXYwQLF_4zgCA&q=info%3Ahttps%3A%2F%2Fdeveloper.mozilla.org%2Fen-GB%2Fdocs%2FTools%2FNetwork_Monitor&oq=info%3Ahttps%3A%2F%2Fdeveloper.mozilla.org%2Fen-GB%2Fdocs%2FTools%2FNetwork_Monitor&gs_l=psy-ab.3...2970.3523.0.3846.4.4.0.0.0.0.51.195.4.4.0....0...1.1.64.psy-ab..0.0.0....0.9EIsqaUrpd0

In general mdn provides no hreflang to help Google with the languages and so some of this weird language mixups is the result. But usually not with versions, never been live.

How to get it out? A 301 redirect should be the fastest option. Maybe even for the whole folder /en-GB/ with all subpages to /en-US/ and its subsites, although I found only around 50 external inlinks to en-GB, so it seems not like a wide spread problem. A general fallback to the en-US version for all locales if not available anymore seems maybe like a good way to go.
Flags: needinfo?(rraue)
MDN Web Docs' bug reporting has now moved to GitHub. From now on, please file content bugs at https://github.com/mdn/sprints/issues/ and platform bugs at https://github.com/mdn/kuma/issues/.
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.