Closed Bug 1472455 Opened 3 years ago Closed 3 years ago

artifacts on spiegel.de

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- disabled
firefox61 --- disabled
firefox62 --- disabled
firefox63 --- disabled
firefox64 --- fixed

People

(Reporter: beingalink, Unassigned)

References

(Blocks 2 open bugs, )

Details

(Keywords: nightly-community, regression, Whiteboard: [gfx-noted])

Attachments

(4 files)

Attached image artifact_spiegel_de.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180630100552

Steps to reproduce:

1) Open http://www.spiegel.de/ --> scroll down the page
2) Click a menu button for a 3rd party addon (Bitwarden or uBlock Origin)


Actual results:

1) Artifacts appear --> see screenshot attached
2) The menu appears much slower than with webrender disabled and there's an artifact at the top --> see screenshot


Expected results:

1) There should not appear any artifact
2) The menu should appear at the same speed as with webrender disabled (or faster) and there should be no artifact
Hardware: MacBook Pro (13-inch, Late 2016, Two Thunderbolt 3 ports)
Grafics: Intel Iris Graphics 540 1536 MB
MacOS 10.13.5
Please
1. Enter about:support into the address bar.
2. Click the "Copy text to clipboard" button.
3. Paste the text into a text editor and save the file.
4. Click the "Attach File" link above comment 0 to upload it.
Component: Untriaged → Graphics: WebRender
Flags: needinfo?(beingalink)
OS: Unspecified → Mac OS X
Product: Firefox → Core
Version: 63 Branch → Trunk
(In reply to beingalink from comment #0)
> 1) Artifacts appear --> see screenshot attached
I couldn't reproduce this on Debian Testing (GTX 1060).

> 2) The menu appears much slower than with webrender disabled
Speculative and maybe wrong: Would it help if you create gfx.webrender.program-binary;true and gfx.webrender.program-binary-disk;true on about:config and restart Nightly? (bug 1467358)

> and there's an artifact at the top --> see screenshot
bug 1444595 is about that.
Attached video 2018-06-30_20-06-05.mp4
Nightly 63 x64 20180630100552 de_DE @ Debian Testing (GTX 1060)
fresh profile, gfx.webrender.all;true, installed uBlock Origin (not needed).

I assume I see the same bug as you, but only exact at 150% zoom.
Attached file support_info.txt
Flags: needinfo?(beingalink)
I attached the support info file.

> I assume I see the same bug as you, but only exact at 150% zoom.

As this Macbook has a high dpi screen I guess zooming might be automatically involved here. I didn't change any setting though.
> Speculative and maybe wrong: Would it help if you create gfx.webrender.program-binary;true and gfx.webrender.program-binary-disk;true on about:config and restart Nightly?

This didn't change anything regarding menu rendering time.
On Win10 (GTX 1060) I could only reproduce with force-angle=false so far and it looks exactly as on Debian (comment 5).

mozregression --good 2018-01-15 --bad 2018-06-30 --pref gfx.webrender.all:true gfx.webrender.force-angle:false startup.homepage_welcome_url:'http://www.spiegel.de/'
> 7:59.13 INFO: Last good revision: 5110a382f6a073a9fa220936442125c961bc57af
> 7:59.13 INFO: First bad revision: 8a988d1a6f23f900b90c7843e2c61db14a57e56c
> 7:59.14 INFO: Pushlog:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5110a382f6a073a9fa220936442125c961bc57af&tochange=8a988d1a6f23f900b90c7843e2c61db14a57e56c

> 8a988d1a6f23	Kartikaya Gupta — Bug 1443807 - Update reftest annotations for changes in WR PR 2487. r=jrmuizel
> 1bc8b8422379	Kartikaya Gupta — Bug 1443807 - Update webrender to commit 5cb71f0f23719795e7c89417d91a7abad8ac20e9. r=jrmuizel

The same WR update caused bug 1452351.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Mac OS X → All
Summary: Problems with webrender on Nightly/MacOS → artefacts on spiegel.de
Summary: artefacts on spiegel.de → artifacts on spiegel.de
The artifacts on spiegel.de seem to be gone with today's nightly. The other issues are still there though.
Hopefully I didn't hijack your report: I can still reproduce comment 5.
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #11)
> Hopefully I didn't hijack your report: I can still reproduce comment 5.

I'm on MacOS. Perhaps it's a bit different on Linux?
I guess the target platform should be switched to Linux as it's fine on MacOS for quite a while now (and never was a problem on windows). Also the visual glitch on addon widgets seems to be gone now. The only issue left is that these widgets still open quite slow on MacOS with webrender enabled.
OS: All → Linux
See Also: → 1449661
Priority: -- → P3
Whiteboard: [gfx-noted]
mozregression --find-fix --bad 2018-09-01 --good 2018-09-26 --pref gfx.webrender.all:true -a http://www.spiegel.de/wissenschaft/
> 8:57.03 INFO: First good revision: 14c6b338e32c1da04218311b26e14cd2b9a3102b
> 8:57.03 INFO: Last bad revision: a1a0f861a0ae43b0a5668aa292e4705885ff19be
> 8:57.03 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a1a0f861a0ae43b0a5668aa292e4705885ff19be&tochange=14c6b338e32c1da04218311b26e14cd2b9a3102b

> 14c6b338e32c	Jeff Muizelaar — Bug 1492566. Update webrender to f17f6a491d6ff3dc3e13e998dda788d8f5856338
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1492566
Flags: needinfo?(jan)
Resolution: --- → WORKSFORME
Flags: needinfo?(jan)
You need to log in before you can comment on or make changes to this bug.