Closed Bug 1472750 Opened 5 years ago Closed 5 years ago

Convert simple "listbox" instances to "richlistbox"


(Firefox :: General, defect, P1)




Firefox 63
Tracking Status
firefox63 --- fixed


(Reporter: Paolo, Assigned: Paolo)




(1 file)

This covers the simple cases from bug 1472554.
Is it always the case that 1 row = 20px, or does this change the height in some cases?
No, the lists are generally slightly taller than before. The exact item height generally depends on the font size, which can change a bit between platforms.
Comment on attachment 8989220 [details]
Bug 1472750 - Convert simple "listbox" instances to "richlistbox".

I've actually realized that there are additional focus-related styles applied to "listitem" but not "richlistitem". I'm thinking of adding an attribute like styling="listbox" on the "richlistbox" elements I'm converting here.
Attachment #8989220 - Flags: review?(bgrinstead)
Blocks: 1472748
Depends on: 1473521
I've ported the fancy selection styling from "listbox" mainly for the benefit of the "Edit This Bookmark" panel in bug 1472748. The richlistboxes updated here are secondary or rarely used UI, so the basic style might have worked as well, but I've included it here so all the lists appear exactly as before.

I've not ported one or two styles for disabled items because they are unused.
Comment on attachment 8989220 [details]
Bug 1472750 - Convert simple "listbox" instances to "richlistbox".

::: browser/components/preferences/siteDataRemoveSelected.xul:48
(Diff revision 2)
> -    <separator />
> +    <separator/>
> -    <vbox flex="1">
> -      <label data-l10n-id="site-data-removing-table"/>
> +    <label data-l10n-id="site-data-removing-table"/>
> -      <separator class="thin"/>
> +    <separator class="thin"/>
> -      <listbox id="removalList"/>
> +    <richlistbox id="removalList" styled="true" flex="1"/>

`[styled=true]` isn't very descriptive of what's happening here. I'd suggest (1) using a class instead of an attribute since this is only used for styling purposes and (2) renaming it to something that more explains what's going on - maybe `.listbox`, or `.theme-listbox`, or something?
Comment on attachment 8989220 [details]
Bug 1472750 - Convert simple "listbox" instances to "richlistbox".
Attachment #8989220 - Flags: review?(bgrinstead) → review+
Pushed by
Convert simple "listbox" instances to "richlistbox". r=bgrins
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Depends on: 1475916
Depends on: 1475202
See Also: 1475202
Depends on: 1480158
You need to log in before you can comment on or make changes to this bug.