Closed Bug 1472797 Opened Last year Closed Last year

Add OS information to filter expression

Categories

(Firefox :: Normandy Client, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: mythmon, Assigned: mythmon)

References

Details

Attachments

(1 file)

OS information is currently available in Telemetry, but it is rather awkward to use. We should add a new set of context variables to support filtering by OS details.

I propose:

Three booleans, to indicate the current OS:
- os.isWindows
- os.isMac
- os.isLinux

And some version information:
- os.windowsVersion - A number like 6.1, 6.2, or 10.0, representing the internval Windows versions (IE, "Windows 8" is actually version 6.2)
- os.windowsBuild - A number like 7600 or 16299, representing the intra-version builds of Windows.

- os.macVersion - A number like 10.7 or 10.12.
- os.macDarwinVersion - A number like 9 (used in OSX 10.5), or 16 (used in macOS 10.12).


Of note is that all of the values above are booleans or numbers, not strings. This goes against common practice for version numbers, but I think that the extra complexity that string versions would provide would not be helpful.

Additionally, no version information would be provided for Linux. I don't think Firefox needs to know the kernel version of Linux, and trying to herd the versions of the various distributions of Linux (such as Ubuntu 18.04 or Debian Stretch) doesn't seem worth it.

Finally, especially for Windows, I'd expect nicer UIs to be built in filter objects or Delivery Console to allow users to manipulate all this.
Assignee: nobody → mcooper
Status: NEW → ASSIGNED
Comment on attachment 8989302 [details]
Bug 1472797 - Add OS information to filter expression context

:Gijs (he/him) has approved the revision.

https://phabricator.services.mozilla.com/D1920
Attachment #8989302 - Flags: review+
Comment on attachment 8989302 [details]
Bug 1472797 - Add OS information to filter expression context

:Gijs (he/him) has requested changes to the revision.

https://phabricator.services.mozilla.com/D1920
Attachment #8989302 - Flags: review+
Comment on attachment 8989302 [details]
Bug 1472797 - Add OS information to filter expression context

:Gijs (he/him) has approved the revision.

https://phabricator.services.mozilla.com/D1920
Attachment #8989302 - Flags: review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3416a349e134
Add OS information to filter expression context r=Gijs
https://hg.mozilla.org/mozilla-central/rev/3416a349e134
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Duplicate of this bug: 1293745
You need to log in before you can comment on or make changes to this bug.