Closed Bug 1472835 Opened Last year Closed Last year

`parentsWithGaps` shouldn't count the root

Categories

(Firefox :: Sync, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- fixed
firefox63 --- fixed

People

(Reporter: Lina, Assigned: Lina)

References

Details

(Keywords: regression)

Attachments

(1 file)

...Since the root is its own parent. This also means we currently report 1 gap for everyone. :-(
This explains why these values are so high then, thanks Lina
Comment on attachment 8989288 [details]
Exclude the root from the `parentsWithGaps` check in the bookmarks mirror.

Mark Hammond [:markh] has approved the revision.

https://phabricator.services.mozilla.com/D1918
Attachment #8989288 - Flags: review+
Pushed by kcambridge@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a68714d7bf33
Exclude the root from the `parentsWithGaps` check in the bookmarks mirror. r=markh
Comment on attachment 8989288 [details]
Exclude the root from the `parentsWithGaps` check in the bookmarks mirror.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1461009.
[User impact if declined]: Telemetry dashboards for problems with new bookmark sync will be wrong.
[Is this code covered by automated tests?]: Yes.
[Has the fix been verified in Nightly?]: Not yet.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Small change with test coverage; also, new bookmark sync is pref'd off by default on Beta.
[String changes made/needed]: None.
Attachment #8989288 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/a68714d7bf33
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 8989288 [details]
Exclude the root from the `parentsWithGaps` check in the bookmarks mirror.

Telemetry fix, sounds pretty safe since this is preffed off by default. This should land for beta 6.
Attachment #8989288 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.