composer stores absolute file names for jpg images after cut and paste

VERIFIED DUPLICATE of bug 32768

Status

VERIFIED DUPLICATE of bug 32768
17 years ago
14 years ago

People

(Reporter: leavens, Assigned: Brade)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

It seems that composer stores absolute URLs for images
   file:///c:/.../file.jpg
instead of relative ones whenever I cut an image and paste it somewhere else in
the document.  I can't figure out how to set it to store
relative file names in preferences.

Absolute file names aren't good for publishing web pages.

Reproducible: Always
Steps to Reproduce:
1. Start up composer on an existing web page with images (IMG tag).
2. Cut an existng image.
3. Move the cursor using the mouse.
4. Paste the image somewhere new.
5. Note that the file name is relative.
It may be necessary to work on a different partition than where composer starts,
at least that's what I'm doing.

Actual Results:  I get an absolute path to the file name.

Expected Results:  Since the image started with a relative file name, I wanted
a relative file name when finished.  I don't want to check a box each time.

Comment 1

17 years ago
I have confirmed this occurs after cutting'n pasting _any_ object (image, URL,
etc...) in Mozilla 0.9.9 on Linux (Ximian).  I have just confirmed it again in
Mozilla 1.0.0 on Windows (Mozilla.ORG .exe).
(Assignee)

Comment 2

17 years ago
-->brade (probably a duplicate bug)

note: when you publish the url will be changed to be relative to the publishing
location (if it's possible to be relative to that)
Assignee: syd → brade
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 3

16 years ago
Confirmed also in 1.1...
very annoying behaviour that is hard to spot, because you check uploaded pages
from the same location that you created web pages, and everything 'looks ok'
even when it's not...

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 32768 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

16 years ago
verified dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.