Closed Bug 1472943 Opened 4 years ago Closed 4 years ago

Firefox not using latest synchronization information

Categories

(Firefox :: Sync, defect)

61 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1353641
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix

People

(Reporter: richard.focke, Unassigned)

Details

Attachments

(6 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180621125625

Steps to reproduce:

1. Setup two PCs with Firefox synchronization (PC 1 and PC 2)
2. Create a custom toolbar and/or organize your folders on one PC 1 with firefox closed on the other.
3. Optionally close firefox on the first PC 1.
4. Open firefox on the second PC 2, and the folders order will be reverted.


Actual results:

Folder sorting and order is not maintained from the latest synchronization information. Instead a stale version from an unopened browser takes precedence.


Expected results:

Folder sorting should be maintained as per the latest synchronization information.
I've reproduced the issue on Fx61.0.1 20180704003137, Fx63.0a1 20180706100210, Fx 60.1.0esr
20180621121604, Fx52.9.0 20180621064021 on Ubuntu 16.04/ Windows 10.
Status: UNCONFIRMED → NEW
Component: Untriaged → Firefox Sync: Backend
Ever confirmed: true
Product: Firefox → Cloud Services
This sounds a lot like bug 1474033, but that only affects 62+, and I see the original report says 61. Richard, are you using Beta 62 or Nightly 63 on any of your PCs?
Flags: needinfo?(richard.focke)
Hi Lina, I am using 61 at the moment, and ESR on my work machine Windows VM. I have tested with and without the ESR and it does not appear to be the cause. I still don't have the beta version 62 installed. However, I do have the Nightly 63 on one machine, but I did not use it for the testing. Would you like me to test with that too?
Flags: needinfo?(richard.focke)
Thanks, Richard!

I can't reproduce with two Firefox 61 installs (or two 61s and an ESR 52) yet...once I sign in to a device running 62 or 63, the moves start getting reverted, but not with just 52/61. I'll keep poking at it, though.

In the meantime, if you have cycles to help us debug, could you please install the About Sync add-on (https://addons.mozilla.org/en-US/firefox/addon/about-sync/), open about:sync, set "Actively looking for issues and want detailed logging" under the "General Options" section, and test again?

When you notice the moves are reverted, please download the logs as a zip file (there's a link under "Log Files and Diagnostics" in about:sync), and attach them to this bug, along with an anonymized "validation export" ("Data provider options" section at the bottom). That'll give us a better idea of what your devices are doing.

Also, could you please check if you have the `services.sync.engine.bookmarks.buffer` pref enabled or disabled in about:config?
Flags: needinfo?(richard.focke)
I am busy installing the about-sync addon. I will test a bit further tonight. Unfortunately, my day schedule is very busy so I probably won't be able to test before then. The flag `services.sync.engine.bookmarks.buffer` is false in my about:config on the two Firefox 61.0.1 instances. This seems to be a new setting my Firefox ESR 52.9.0 (32-bit) does not have it - I am using this predominantly to access some pages serving Java applets.
Flags: needinfo?(richard.focke)
Synchronization was done around 07:05
Synchronization completed at 07:05 but no new log file present.
Ok, I quickly tested with the plugin. What I see is that on the machine, where I re-order the bookmarks the synchronization, is the bookmark order is uploaded to the server. On the other machine, where the synchronization was meant to be pushed, it synchronizes but makes no new log file. Despite having successfully synchronized. I assumed with the plugin option that a log file would always be created? I have attached all the log files created, but have not removed any older logs.
Synchronization finally kicks in fully and order is now jumbled (neither order maintained).
Relaunched firefox and bookmarks are jumbled even on main machine.
Launching Firefox again on the master machine (where the changes were first made) now leads to both machines having random ordering of bookmarks.
As you say, the logs show that around 15:05, some items were moved on the toolbar, and this machine synced. However, the last log from machine 2 is dated 14:57:42. That is a "success" log, so we'd certainly expect future syncs to also write "success" logs. So I've no idea why machine 2 does seem to be syncing, but didn't sync when you expected it to. However, in general, machine 2 does seem to be syncing correctly.

about:sync has a "validation" tab - it would be interesting to know what each of the machines reports there.

Now that you have about:sync installed on both those machines, any logs you send in the future will become a bit clearer, so I look forward to them once you've found time to have another play with this.

(In reply to Richard Focke from comment #11)
> Launching Firefox again on the master machine (where the changes were first
> made) now leads to both machines having random ordering of bookmarks.

Ouch! Could you please attach any new logs from that machine after success-sync-1531285523774.txt?
I also meant to ask: your account appears to have 6 devices connected to the account. Are any of the other 4 Android devices?
Hi Mark, yes two of the devices are Android devices. Would this make a difference? I wasn't using Firefox on the Android at the time but it was connected to the Internet.
Unfortunately, I will only be able to test again tonight.
Sadly we do have a number of Android bugs related to ordering :( It would be very helpful if you can do your testing with these devices disconnected (eg, in Airplane mode) and ensuring that the bad ordering only happens when they are connected.

(In reply to Richard Focke from comment #15)
> Unfortunately, I will only be able to test again tonight.

No problem at all - we are quite busy here too, so it may end up taking us a couple of days to get back to you anyway - so please don't rush on our account!
Seems it is the Android devices causing havoc. With them in flight mode the issue stops happening.
Re-ordering on first machine with Android(s) in flight mode.
I performed the test around 9:00
Thanks! We are tracking the Android reordering issue via bug 1353641
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1353641
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.