"View Source" crashes Mozilla

RESOLVED DUPLICATE of bug 142847

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 142847
16 years ago
13 years ago

People

(Reporter: Mark Slater, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({crash})

Trunk
x86
Windows 98
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0+) Gecko/20020524
BuildID:    2002052408

Every time I want to look at the source of a website via 'View Source', Mozilla
crashes

Reproducible: Always
Steps to Reproduce:
1. Load a website
2. Choose 'View source' from right-click context menu

Actual Results:  Instant Crash

Expected Results:  Show new window with the source of the site

Talkback ID: TB6702477Y

Comment 1

16 years ago
Mark, does it also happen when creating a new profile ? Do you have themes
installed ?
Keywords: crash, stackwanted
stephend, could you get the stack?  TB6702477Y
(Reporter)

Comment 3

16 years ago
Oliver: No additional themes installed. I'm not sure about whether it crashes in
new profiles too, but I'll try tonight again (at work now).

I remember this build also consistently crashing on using CTRL-3 to start
Chatzilla, tho that might be unrelated to this bug.

Perhaps this has something to do with new window creation?
Have you installed over an older build ?
(Reporter)

Comment 5

16 years ago
"Hello, my name is Mark and I just install over old nightlies"
*gasp* from the other attendees of Dumb Mozilla Users Anonymous

I fixed the problem I was encountering. Did the following steps:

1) Saved contents of root .slt folder of the original horked profile
2) Created new profile
3) Started with new profile, no problems, no crashes
4) Copied one file after another (with restarts of moz between copying) to check
which file was causing the crashes

Turns out the culprit is a file called "XUL.mfl". When I copy the file (3.6mb)
to my new profile, overwriting the file that's already there (2.2mb), I
encounter the crashing (both with view source and launching chatzilla). 

Might still be interesting to see what caused the crash. I know, I installed
over old nightlies.. who hasn't? ;)
XUL.mfl is the XUL fastload cache.  The crash was likely caused by a mismatch 
between the cache and the actual XUL....
MSVCRT.DLL + 0x1572 (0x78001572)
nsBufferedInputStream::Read [nsBufferedStreams.cpp, line 281]
nsFastLoadFileReader::Read [nsFastLoadFile.cpp, line 569]
nsBinaryInputStream::Read32 [nsBinaryStream.cpp, line 361]
nsXULPrototypeElement::Deserialize [nsXULElement.cpp, line 5053]
nsXULPrototypeDocument::Read [nsXULPrototypeDocument.cpp, line 355]
nsXULPrototypeCache::GetPrototype [nsXULPrototypeCache.cpp, line 274]
nsXULDocument::ResumeWalk [nsXULDocument.cpp, line 5609]
nsXULDocument::EndLoad [nsXULDocument.cpp, line 1793]
XULContentSinkImpl::DidBuildModel [nsXULContentSink.cpp, line 532]
nsExpatDriver::DidBuildModel [nsExpatDriver.cpp, line 939]
nsParser::DidBuildModel [nsParser.cpp, line 1254]
nsParser::ResumeParse [nsParser.cpp, line 1796]
nsParser::OnStopRequest [nsParser.cpp, line 2425]
nsDocumentOpenInfo::OnStopRequest [nsURILoader.cpp, line 256]
nsJARChannel::OnStopRequest [nsJARChannel.cpp, line 609]
nsOnStopRequestEvent::HandleEvent [nsRequestObserverProxy.cpp, line 213]
PL_HandleEvent [plevent.c, line 597]
PL_ProcessPendingEvents [plevent.c, line 530]
_md_EventReceiverProc [plevent.c, line 1078]
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00648bf6 
Keywords: stackwanted
Yep, as expected.  To Ben to decide whether he cares.
Assignee: Matti → ben
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dup of "Trunk crashes launching mail [@ nsBufferedInputStream::Fill] [@
MSVCRT.DLL | msvcrt.dll - nsBufferedInputStream::Read]"

*** This bug has been marked as a duplicate of 142847 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.