Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Freer, Assigned: Matti)

Tracking

({crash, stackwanted})

Trunk
x86
FreeBSD
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Some days early I'm running FreeBSD 4.5 release + X4.1 + Gnome 1.4 + E 0.16, 
and I can run mozilla 0.99, though the speed is slow, but when I run 1.0 RC1 
binary I got error:
segmentation fault

Then I upgraded my X to 4.2 and now running FreeBSD 4.5 release +X4.2 + Gnome 
1.4 + E 0.16, and I have down load the binary of 1.0 RC1, RC2 and RC3, and got 
the same error after run ./run-mozilla.sh or ./mozilla:

segmentation fault


Can anyone tell me why and how to solve it? Many thanks!

Comment 1

16 years ago
Can you create a new profile 'mozilla -profilemanager' ?
If not, is deleteing your old profile ~/.mozilla enables Mozilla to start
correctly ?
Keywords: crash, stackwanted

Comment 2

16 years ago
You should install Mozilla 1.0 RC3 through the ports system:

1) cvsup your ports collection
2) cd /usr/ports/www/mozilla
3) make install

If your box is slow, you can also download the pre-compiled package.

Comment 3

16 years ago
make sure you don't have a second mozilla (eg 0.9.9) in your path
Assignee: aaronl → Matti
Severity: blocker → critical
Status: UNCONFIRMED → NEW
Component: Accessibility APIs → Browser-General
Ever confirmed: true
QA Contact: dsirnapalli → imajes-qa
(Reporter)

Comment 4

16 years ago
I'm sure I don't have second mozilla and I don't have old profile, because I re-
installed my whole system. And compile mozilla need long time on my K6-2 
machine. Is there anything to do with my kernel configuration file?
(Reporter)

Comment 5

16 years ago
And When I run ./mozilla -profilemanager  I got the same error:

segmentation fault

Comment 6

16 years ago
Remove the previous mozilla build:
pkg_info | grep mozilla
pkg_delete name_of_old_mozilla_package

Then install the RC3 package:
pkg_add -r mozilla-1.0.rc3,1.tgz

No compiling needed.
(Assignee)

Comment 7

16 years ago
-> wfm
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.