Closed Bug 1473263 Opened 5 years ago Closed 5 years ago

Font editor: do not show font editor for nodes with zero used fonts

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox63 verified, firefox64 verified)

VERIFIED FIXED
Firefox 63
Tracking Status
firefox63 --- verified
firefox64 --- verified

People

(Reporter: rcaliman, Assigned: rcaliman)

References

Details

Attachments

(2 files)

Steps:

1. go to v-fonts.com
2. open DevTools, inspect the `<head>` element
3. select the Fonts panel

Expected:
No font editor and "No fonts found" message

Result:
Font Editor for non-variable fonts shows up and an empty list of used fonts, because none apply.

This case applies to any scenarios where the node is valid, but has no text content within its descendant nodes (i.e. empty nodes, `<script>`, `<img>`, etc)
Comment on attachment 8989801 [details]
Bug 1473263 - Show "No fonts" message when there are no fonts used on the selected element or its descendants.

https://reviewboard.mozilla.org/r/254774/#review261780
Attachment #8989801 - Flags: review?(pbrosset) → review+
Pushed by rcaliman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71e47b1dfcd0
Show "No fonts" message when there are no fonts used on the selected element or its descendants. r=pbro
https://hg.mozilla.org/mozilla-central/rev/71e47b1dfcd0
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Flags: qe-verify+
QA Contact: catalin.sasca
I successfully reproduced the issue on Firefox Nightly 63.0a1 (2018-07-04) under Windows 10 (x64) using the STR from Comment 0.
The issue is no longer reproducible on Firefox Beta 63.0b12 and latest Nightly 64.0a1 (2018-10-07). Tests were performed under Windows 10 (x64), macOS 10.13, and Ubuntu 16.04 (x64).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Component: Inspector: Fonts → Inspector
You need to log in before you can comment on or make changes to this bug.