Closed Bug 1473264 Opened 3 years ago Closed 3 years ago

Failing to get the favicon expiration time breaks the favicon load.

Categories

(Firefox :: Tabbed Browser, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: mossop, Assigned: mossop)

References

Details

Attachments

(1 file)

In some cases where the favicon requests not to be cached favicons will break.
Assignee: nobody → dtownsend
This ignores failures to get expiration data from favicon requests. It also adds
some safety to the rest of onStopRequest wrapping it in a try...catch block to
catch any unexpected errors and correctly reject the waiting promise.
Comment on attachment 8989705 [details]
Bug 1473264: Catch failures to get the favicon expiration.

Marco Bonardo [::mak] has approved the revision.

https://phabricator.services.mozilla.com/D1938
Attachment #8989705 - Flags: review+
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/19e3352e9f67
Catch failures to get the favicon expiration. r=mak
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/19e3352e9f67
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Duplicate of this bug: 1472474
You need to log in before you can comment on or make changes to this bug.