Closed Bug 1473364 Opened 3 years ago Closed 3 years ago
Threshold is misspelled throughout comm-central
https://dxr.mozilla.org/comm-central/search?q=threshhold&redirect=false Sad problems are: pref("mail.purge_threshhold_mb", 20); pref("mail.prompt_purge_threshhold", true); They can't just be corrected without an expensive migration. Even sadder: mailnews/imap/src/nsImapIncomingServer.cpp 294 NS_IMPL_SERVERPREF_INT(nsImapIncomingServer, EmptyTrashThreshhold, 295 "empty_trash_threshhold") That defines a server preference which is even harder to migrate :-(
This fixes all misspellings which are not in preference names.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8989810 - Flags: review?(acelists)
Comment on attachment 8989810 [details] [diff] [review] 1473364-threshold.patch Review of attachment 8989810 [details] [diff] [review]: ----------------------------------------------------------------- Thanks. ::: mailnews/base/util/nsMsgDBFolder.cpp @@ +72,5 @@ > #include "nsIScriptError.h" > #include "mozilla/intl/LocaleService.h" > #include "nsIURIMutator.h" > > +static PRTime gtimeOfLastPurgeCheck; //variable to know when to check for purge threshold Wasn't this supposed to reference the pref name (even with the typo)? Also, I think we use to have space after // .
Attachment #8989810 - Flags: review?(acelists) → review+
Maybe it was meant to reference the pref, but now it just references the concept in general ;-) I'll fix the comment. Do you have an opinion on writing a whole lot of migration code to fix the pref names of which there are two for purge and a server-level one for the trash "empty_trash_threshhold". However, that's not set, not documented and Google doesn't show any results. So I'll fix that right now leaving only the purge ones. pref("mail.purge_threshhold_mb", 20); pref("mail.prompt_purge_threshhold", true);
Pushed by email@example.com: https://hg.mozilla.org/comm-central/rev/3e12359fd55c fix misspelling of threshold without changing pref names for purge. r=aceman
Someone objected to renaming this, so here is proof that this is unused and I could have renamed it to MickeyMouse ;-) Sure, add-ons can set and read it, but that didn't have any effect since TB never calls the getter, unlike for example GetDualUseFolders().
Attachment #8990146 - Flags: review?(acelists)
Pushed by firstname.lastname@example.org: https://hg.mozilla.org/comm-central/rev/7d53c219810e remove unused nsIImapIncomingServer.emptyTrashThreshold. r=aceman
I think we're done here. Fixing the misspelled preference names is to expensive: https://searchfox.org/comm-central/search?q=purge_threshhold&case=false®exp=false&path=
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0
You need to log in before you can comment on or make changes to this bug.