Closed Bug 1473377 Opened 4 years ago Closed 4 years ago

Building on windows fails during configure step ("TypeError: environment can only contain strings")

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1473331

People

(Reporter: kats, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached file Build output
I just updated my m-c checkout on a windows machine from something ~1 week ago to the latest tip, and now my build is failing. Log attached, relevant portion is this:

 0:03.63   File "c:/Users/kats/zspace/mozilla-wr/build/moz.configure/node.configure", line 29, in nodejs_version
 0:03.63     stderr=subprocess.STDOUT)
 0:03.63   File "c:\mozilla-build\python\Lib\subprocess.py", line 212, in check_output
 0:03.63     process = Popen(stdout=PIPE, *popenargs, **kwargs)
 0:03.63   File "c:\mozilla-build\python\Lib\subprocess.py", line 390, in __init__
 0:03.63     errread, errwrite)
 0:03.63   File "c:\mozilla-build\python\Lib\subprocess.py", line 640, in _execute_child
 0:03.63     startupinfo)
 0:03.63 TypeError: environment can only contain strings

Googling for this error message seems to indicate it happens if there's unicode strings in the 'env' dict, which there are in my case (I checked by dumping it with log.warning).

Presumably something python-related changed recently in the build system that is causing this.
Oh, this check was added recently.
Blocks: 1471028
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1473331
You need to log in before you can comment on or make changes to this bug.