Mozilla does not start after installing XPIs

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
17 years ago
14 years ago

People

(Reporter: defrider71, Assigned: rginda)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052305

I have a feeling I know what the problem is.  In the package contents, in the
MacOS folder, after installing the CZ XPI, there is a document there called
XPICleanup something. Well, the XPI downloads and quits Mozilla and then I
launch it again and it says that I need to restart due to the XPI installation.
 All right, so I hit okay and the classic layer starts up and quits.  I did this
ten times then restarted my computer and it still happened.  That's when I
decided to go into the package contents.  In that textfile, I noticed the path
to a file, chatzilla.old.  I deleted this file manually and then deleted the
text document.  Mozilla opened fine.  Then it struck me, the application XPI
cleanup must be to automatically delete items whos paths are in that text file.
 Double click the app and sure enough, classic mode opens.  What you need it to
compile a new version of the app.  Maybe you made it under X.0.0 and it no
longer works or something...

Reproducible: Always
Steps to Reproduce:
in description

Actual Results:  classic mode opens and I cannot start mozilla

Expected Results:  deleted the path in the file

Comment 1

17 years ago
Greg F., so you install RC3 (which contains Chatzilla), and then install the
Chatzilla XPI?
Summary: mozilla does not start after installing XPI's → Mozilla does not start after installing XPI's
(Reporter)

Comment 2

17 years ago
Yeah, my friend said I needed to type the xpi url into the browser.  I don't
know all that much about mozilla.  But also to add to this, an OS X native app
should never have to launch a classic app...

Comment 3

17 years ago
Greg F., please give us the exact URI you typed, and then list the exact steps
you took that caused the problem. It will be easier to confirm that way.

Thanks.

Updated

17 years ago
Severity: blocker → critical

Comment 4

17 years ago
This is what I think he did:
1.  Installed Mozilla with the Installer, and did a minimal installation or 
custom without ChatZilla checked.
2.  Tried to get on #MozillaZine, and wanted ChatZilla
3.  I told him to type this into the Location field: 
ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla1.0rc3/mac-xpi/chatzilla.xpi

The expected behavior was to Install ChatZilla.

Comment 5

17 years ago
Jake, Mozilla for Mac OS X doesn't offer any installation customization. All
installations include Chatzilla by default.

Comment 6

16 years ago
No response for 8 months. Resolving Invalid since description doesn't make
sense, in that there is no installer on Mac OS X, and Chatzilla is included in
the build by default.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Summary: Mozilla does not start after installing XPI's → Mozilla does not start after installing XPIs
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.