submit button moves when you click on it

RESOLVED DUPLICATE of bug 151230

Status

()

RESOLVED DUPLICATE of bug 151230
16 years ago
16 years ago

People

(Reporter: paul, Assigned: karnaze)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

If a submit button is wrapped in a <CENTER> tag in a form, it will move to the
left when you try to click on it.

Reproducible: Always
Steps to Reproduce:
1. create a form
2. put a table in the form
3. center a table cell
4. put a submit button into the centered table cell
5. try to click it

Actual Results:  the button moved, but it still works

Expected Results:  the button shouldn't move

Comment 1

16 years ago
Well, my submit button doesn't move...

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3) Gecko/20020523
Build ID: 2002052306

Perhaps you could supply a testcase?

Comment 2

16 years ago
WFM Mac OS 9.1 build 2002052305 (1.0RC3)

Comment 3

16 years ago
oh, its moving for me ;-) RC3 (2002052306) on WinMe. The button flips about 2cm
left as soon as you press the mouse button. And it doesn't move back if you
release the button...

The problem (missing this in bug description) seems to be a "colspan=2" in the
<td> tag. Removing this stops moving the button. I'll provide two testcases
(perhaps somebody can add the keyword, I can't).

Comment 4

16 years ago
Created attachment 85202 [details]
moving submit-button

Comment 5

16 years ago
Created attachment 85203 [details]
same code without "colspan" attribute don't move
(Reporter)

Comment 6

16 years ago
Created attachment 85209 [details]
a test case that still has the problem

Here is an example that illustrates the problem. Note that there is a table
with two columns, the left column and the right column. Below them is another
column with COLSPAN=2 that has the problem. Maybe again I'm missing something.

Comment 7

16 years ago
Yup, now it moves for me as well (both testcaes)... Mac OS 9.1 build 2002052305
(1.0RC3)

Comment 8

16 years ago
dito. It is moving, but now with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.0.0) Gecko/20020530 Build ID: 2002053012

But I think I can't set this keyword, too...
Paul Smith: your bug needs you

Comment 9

16 years ago
I see this behavior on win 2k trunk build 2002060704, marking new
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 10

16 years ago
I'm changing it to the "All" status because it happens on me in Win2k, Redhat
Linux and apparently for someone else in MacOS 9.1
OS: Windows 2000 → All
(Reporter)

Updated

16 years ago
Hardware: PC → All

Comment 11

16 years ago
can you take a look?
Assignee: rods → jkeiser
Karnaze, this sounds like a table thing to me.  The click of the button causes a
reflow because its style changes.
Assigning to karnaze, the wizard of table triage.  Bounce 'er back if it doesn't
fit there.
Assignee: jkeiser → karnaze
Component: HTML Form Controls → HTMLTables
QA Contact: tpreston → amar
(Assignee)

Comment 14

16 years ago

*** This bug has been marked as a duplicate of 151230 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.