If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

TestXMLExtras crashes when parsing xml documents

RESOLVED INVALID

Status

()

Core
XML
--
critical
RESOLVED INVALID
16 years ago
8 years ago

People

(Reporter: Mostafa Hosseini, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

({crash})

Trunk
Future
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla 1.0 RC3
Redhat linux 7.1

Parser crashes occasionally when trying to parse an xml file.
Steps to reproduce: 
-Compile TestXMLExtras in mozilla/htmlparser/tests
-Run ./TestXMLExtras parse settings.xml ( provided as attachment ) several times

Result: Occasional segfaults.

Related info: 
-ResumeParse in nsParser.cpp line 2410 is causing the crash.
-Calling parseFromStream several times in a row will make the crash %100
reproducable
-Calling parseFromString giving an empty string definitely causes a crash
(Reporter)

Comment 1

16 years ago
Created attachment 85169 [details]
sample xml file to be parsed

Updated

16 years ago
Keywords: crash
(Reporter)

Comment 2

16 years ago
Update on bug:
Invoking listener->OnDataAvailable() in ::parseFromStream located in
nsDomParser.cpp returns an error (NS_ERROR_NOT_IMPLEMENTED ) result which is not
checked for and thus execution continues leading to a crash.
The NS_ERROR_NOT_IMPLEMENTED error is in its turn caused by calling ReadSegments
in nsParser::OnDataAvailable on an input stream of type nsIFileChannel which
doesn't implement this method.
(Reporter)

Updated

16 years ago
Keywords: oeone
Target Milestone: --- → mozilla1.0

Comment 3

16 years ago
--> heikki

Btw, TestXMLExtras is _not_ under htmlparser module

the correct location is mozilla/extensions/xmlextras/tests
Assignee: harishd → heikki
Severity: critical → normal
Target Milestone: mozilla1.0 → ---
Target Milestone: --- → Future

Comment 4

15 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical
Component: Parser → XML
Summary: Parser crashes when parsing xml documents → TestXMLExtras crashes when parsing xml documents
QA Contact: moied → xml

Comment 5

8 years ago
TestXMLExtras no longer exists.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.