Closed Bug 1473818 Opened Last year Closed Last year

0.34 - 1.11% compiler_metrics num_static_constructors (osx-cross, windows2012-32, windows2012-64) regression on push 05329bb2ebf89f407e0c7ec1e35280e7b2cd11c8 (Thu Jul 5 2018)

Categories

(Core :: JavaScript: GC, defect)

Unspecified
All
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed

People

(Reporter: igoldan, Assigned: wcosta)

References

Details

(Keywords: regression)

Attachments

(1 file)

We have detected a build metrics regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=05329bb2ebf89f407e0c7ec1e35280e7b2cd11c8

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  1%  compiler_metrics num_static_constructors osx-cross opt      90.00 -> 91.00
  1%  compiler_metrics num_static_constructors windows2012-32 pgo 470.00 -> 473.00
  1%  compiler_metrics num_static_constructors windows2012-32 opt 532.00 -> 535.00
  1%  compiler_metrics num_static_constructors windows2012-64 pgo 561.00 -> 564.00
  1%  compiler_metrics num_static_constructors windows2012-64 opt 573.00 -> 576.00
  0%  compiler_metrics num_static_constructors windows2012-64 debug 880.00 -> 883.00
  0%  compiler_metrics num_static_constructors windows2012-32 debug 888.00 -> 891.00


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=14203

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Build_Metrics
Flags: needinfo?(wcosta)
Component: General → JavaScript: GC
Product: Testing → Core
I believe this is due to this line of code introduced [1]. To avoid the global constructor, we could do a lazy evaluation by moving the unlimitedDeadline member to a member function. Let me give it a try

[1] https://hg.mozilla.org/mozilla-central/file/tip/js/src/gc/GC.cpp#l3254
Flags: needinfo?(wcosta)
I pushed a patch but I don't know how to trigger build metrics against it. Can I do it through try syntax?
Flags: needinfo?(igoldan)
build metrics are generated during the build proper, it isn't a unit test or anything like that.

For example, here you can see:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-searchStr=windows%20build&selectedJob=186796089

the highlight job brings up the performance tab in the lower pane where you can see the various performance metrics we collect about a build.
The patch fixed the regressions: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6c26ce382b753979f8860aa5e111d57de70b892a&selectedJob=186885036
Assignee: nobody → wcosta
Status: NEW → ASSIGNED
Comment on attachment 8990381 [details]
Bug 1473818: Fix global constructors count regression

https://reviewboard.mozilla.org/r/255462/#review262784
Attachment #8990381 - Flags: review?(jcoppeard) → review+
Pushed by wcosta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0cf891618219
Fix global constructors count regression r=jonco
https://hg.mozilla.org/mozilla-central/rev/0cf891618219
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
(In reply to Wander Lairson Costa [:wcosta] from comment #3)
> I pushed a patch but I don't know how to trigger build metrics against it.
> Can I do it through try syntax?

Removing ni? as :jmaher already answered that.
Flags: needinfo?(igoldan)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.