Closed Bug 1473820 Opened 6 years ago Closed 6 years ago

about:addons section holding the list gets a large dotted selection rectangle drawn, when clicked

Categories

(Toolkit :: Add-ons Manager, defect, P5)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- verified
firefox65 --- verified

People

(Reporter: cfogel, Unassigned)

References

Details

(Keywords: regression)

Attachments

(3 files)

[Affected versions]:
- Firefox 61.0.1, 62.0b6, 63.0a1 (2018-07-05) 

[Affected platforms]:
- macOS 10.13.4, Windows 10 x86, Ubuntu 16.04 x64

[Steps to reproduce]:
1. Launch firefox;
2. Click on the 3line-hamburger menu button;
3. Click on the Addons option;
4. Click on the Themes or plugins section;
5. Click on the div/section holding the themes.

[Expected result]:
- Nothing is selected/highlighted.

[Actual result]:
- The section is marked as selected.

 
[Additional notes]:
- on macOS, selection is present on clicking the Enable buttons as well;
- attached screenshot with the issue.
On win10x64 it's not reproducible.
Will come up with a regression frame as soon as possible, managed to reproduce on 49.0a1 (2016-05-01) so it's not something new.
Keywords: regression
Mozregression result:

Last good revision: 7723b15ea695 (2015-05-01)
First bad revision: 1e8d30cb367e (2015-05-02)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7723b15ea695&tochange=1e8d30cb367e
(In reply to Cristi Fogel [:cfogel] from comment #2)
> Mozregression result:
> 
> Last good revision: 7723b15ea695 (2015-05-01)
> First bad revision: 1e8d30cb367e (2015-05-02)

It looks like this range involved an addons manager UI redesign. This is presumably just a regression from that redesign.

--> Reclassifying.
Component: Layout → Add-ons Manager
Product: Core → Toolkit
Summary: about:addons section holding the list is selected on clicks → about:addons section holding the list gets a large visible selection rectangle drawn, when clicked
I think the redesign was:
> https://hg.mozilla.org/mozilla-central/rev/3b4fa5cc6210
> Richard Marti — Bug 989469 - Use new style for add-on manager. ui-r=mmasalaney r=mossop CLOSED TREE
Blocks: 989469
Summary: about:addons section holding the list gets a large visible selection rectangle drawn, when clicked → about:addons section holding the list gets a large dotted selection rectangle drawn, when clicked
I can't reproduce in 64+ and I believe it was fixed by the redesign of the addons listing in bug 1490366, so marking as fixed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Agreed, marking as verified  as well. 
Confirmed with 64.0b11 and 65.0a1 (2018-11-20).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: