http: home page images don't display from a page viewed with FILE: url

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Dave Dyer, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    1.0 rc 2

images refereced using HTTP urls display as broken links
if the home pagewas fetched using a FILE url, HTTP image
links display as broken images.

Reproducible: Always
Steps to Reproduce:
1. view the referenced page, note that the page displays normally.
2. copy the page to a local file, being careful to defeat your browser's 
attempts to relocate and alter image links.  Easiest is to use view source
and then cut/paste the result into a new file.  Use open file to view
the file and make the current page your home page.
3. relaunch the browser.  Note that all the images of your new home page
fail to display, but two (the portrait and seti-at-home images) ought
to display because they are HTTP urls.

Comment 1

16 years ago
Reporter,

This works for me in the June 2nd build. I copied the page source into a text
editor app then saved the file as html. Set this page as my default page from my
local drive. Deleted browser cache and quit app. After relaunching app, the HTTp
image rendered on the page (for me). Please try with a newer build and provide
any additional information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.