no error indication for mailto: form when MailNews not installed

RESOLVED FIXED

Status

()

Core
Document Navigation
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: Adam Lock)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If I wasn't so used to Mozilla's poor handling of mailto: when MailNews isn't
installed, I would be quite puzzled why the form on the URL above doesn't submit.

Perhaps an error dialog would be useful?
This is a dup of the general "trying to load a url with an unknown scheme by
clicking or via form action does not give an error" bug....
(Reporter)

Comment 2

16 years ago
I don't think so. Links show where they go at least when you hover. If not for
the hints on the page, it would be very unexpected why the form does not work.
mailto forms are rare (for good reason), and I think most definatly a differant
case then a href=foo:, since form actions require custom code for each action.
Wel.. seeing as we completely lack support for mailto: actions anyway at the 
moment, there is in fact no custom code.  Form submissions just ends up calling 
nsWebShell::OnLinkClickSync with the eLinkVerb_Replace verb.  This just calls 
nsDocShell::InternalLoad, which is what any link click will do.  Unfortunately, 
InternalLoad has poor reporting of load failures....

Imo, trying to load a link "foo:bar" and submitting to "foo:bar" should return 
the same error message (and the same code is involved in both cases).

Comment 4

16 years ago
uid is being phased out.
Assignee: mpt → adamlock
Component: User Interface Design → Embedding: Docshell
QA Contact: zach → adamlock
(Assignee)

Comment 5

16 years ago
Boris, is this fixed by your checkin for that other bug?
It should be, yes. I have no mailnews-less build on hand to test with, however.
 jmd, could you try tomorrow's build?
Depends on: 86486
(Reporter)

Comment 7

16 years ago
Now I get: "mailto is not a registered protocol."
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.