Closed Bug 1474326 Opened Last year Closed Last year

Firefox 60 crash when opening gtk dialogs

Categories

(Core :: Widget: Gtk, defect, critical)

60 Branch
All
Linux
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: jwright, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [DUPEME?])

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36

Steps to reproduce:

This issue occurs in RHEL 6.x with Firefox firefox-60.1.0-5.el6, both i686 and x86_64 versions

Open a 'file save' or 'file open' dialog with any URL (example: right-click on an image and save it)


Actual results:

Crash

(firefox:30405): GLib-GIO-ERROR **: No GSettings schemas are installed on the system
Trace/breakpoint trap (core dumped)


Expected results:

No crash
This issue can be fixed by changing the exec line in /usr/bin/firefox per https://bugzilla.redhat.com/attachment.cgi?id=1455568
Possible duplicate.
Bug 1345921
Bug 1383453
Bug 1385693
Severity: normal → critical
Component: Untriaged → Widget: Gtk
Keywords: crash
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → All
Whiteboard: [DUPEME?]
This is not a bug in upstream codebase. This is because we had to bundle gtk3 for older distros and there's been some difficulties.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → INVALID
I use firefox 64. Linux mint 19.1. I have this problem when trying to save a file. The patch didn't work.

It's december 25 2018.

Running firefox in a terminal:

(firefox:9202): GLib-GObject-WARNING **: 09:56:08.769: ../../../../gobject/gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x7f19dd59cb00' of type 'MaiAtkType139'

(firefox:9202): GLib-GObject-WARNING **: 09:56:16.051: ../../../../gobject/gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x7f19dc9d4240' of type 'MaiAtkType139'

(firefox:9202): GLib-GObject-WARNING **: 09:56:24.632: ../../../../gobject/gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x7f19deeb41a0' of type 'MaiAtkType13b'

(firefox:9202): GLib-GObject-WARNING **: 09:56:24.905: ../../../../gobject/gsignal.c:3492: signal name 'selection_changed' is invalid for instance '0x7f19deeb41a0' of type 'MaiAtkType13b'
You need to log in before you can comment on or make changes to this bug.