Email body becomes gibberish after detaching/deleting attachment if message is encoded base64

RESOLVED DUPLICATE of bug 1473893

Status

defect
RESOLVED DUPLICATE of bug 1473893
10 months ago
10 months ago

People

(Reporter: bws42, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 months ago
I believe this issue began with the update to Thunderbird 52.9.0.

When removing an attachment from an email, the message body appears to be damaged. Looking at the source of the message, one of the base64 encoded sections has non-base64 encoded text.
(Reporter)

Comment 1

10 months ago
I can confirm that this issue is not present in Thunderbird 52.8.0.

Comment 2

10 months ago
This is bug 1473893
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1473893

Comment 3

10 months ago
Can you try a candidate build of TB 52.9.1 please:
http://ftp.mozilla.org/pub/thunderbird/candidates/52.9.1-candidates/build3/
(Reporter)

Comment 4

10 months ago
Detaching attachments using the final TB 52.9.1 release works as expected

Comment 5

10 months ago
For "post mortem" investigation purposes I reverted the fix from bug 1473893 in my local build and added some debug.

I see this:
=== option 14
=== before parsing
VGhpcyBpcyB0ZXh0

===
=== after parsing
<html><head>
<meta http-equiv="content-type" content="text/html; charset="></head><body>VGhpcyBpcyB0ZXh0
</body></html>
===

So for attachment processing (option 14), the undecoded base64 body was sent to our new class 'mimeInlineTextHTMLParsedClass' and that added HTML tags to it. Of course havoc ensued. So the fix for bug 1473893 was not only working but also correct :-)
You need to log in before you can comment on or make changes to this bug.