about:restartrequired content isn't centered like other Firefox error pages

RESOLVED DUPLICATE of bug 1475025

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1475025
10 months ago
10 months ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
STR:
1.  In 3 tabs, visit these 3 sites:
   about:restartrequired
   about:sessionrestore
   http://boguslalala.mozilla.com/
      (note: ^^ intentionally not a real page, to trigger "can't connect")

 2. Compare the critter/text alignment between the three tabs.

ACTUAL RESULTS:
- The about:restartrequired text and critter aren't vertically centered at all (their position doesn't change regardless of window height, except at very small window heights)
- The about:sessionrestore critter and text are kinda centered (they shift down slightly as I make the window taller)
- The "can't connect" mozilla.com URL critter and text seem to be more centered (though the text moves down more than the critter when I resize my window).



EXPECTED RESULTS: consistency.



Not sure which is the correct/expected centering behavior here.
(Reporter)

Updated

10 months ago
Attachment #8990795 - Attachment description: screencast comparing these 3 pages (first static, and then responsiveness to window resizing) → screencast comparing these 3 pages (first the static view, and then responsiveness to window resizing)
(Reporter)

Comment 2

10 months ago
"about:restartrequired" definitely feels like the outlier here, so I think that's the one that needs the most tweaking.

--> adding dependency on bug 1366808 where that page's UI was added.
Depends on: 1366808
Component: General → Theme
Priority: -- → P5
(Reporter)

Comment 3

10 months ago
Actually, this is a regression, and is a special case of bug 1475025 where I've captured this more concisely & identified the guilty changeset. --> Duping forward.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
No longer depends on: 1366808
Resolution: --- → DUPLICATE
Summary: about:restartrequired content isn't centered like all other Firefox error pages → about:restartrequired content isn't centered like other Firefox error pages
Duplicate of bug: 1475025
You need to log in before you can comment on or make changes to this bug.