[Linux] Graphical glitch when unmaximizing

RESOLVED DUPLICATE of bug 1447775

Status

()

defect
RESOLVED DUPLICATE of bug 1447775
10 months ago
8 months ago

People

(Reporter: etai.choset, Unassigned)

Tracking

(Blocks 1 bug)

61 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Posted video output.mp4
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180701122059

Steps to reproduce:

Unmaximized the Firefox window on Linux with the title bar disabled (utilizing Firefox's CSD feature on Linux that was introduced in ver 60)

Environment info:
Distro: Solus 3.9999
X11: X.Org 1.19.6
Kernel: 4.17.2-78.current x86_64
Desktop: Budgie 10.4-85
Graphics: Intel graphics i915 driver
OpenGL: 4.2 Mesa 18.1.1


Actual results:

When unmaximzing, a white line appears between the tab bar and the tool bar
Enabling and disabling the menu bar (by using the Alt key) fixes this


Expected results:

The white bar should not appear

Updated

10 months ago
Blocks: gtktitlebar
Has STR: --- → yes
Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
Duplicate of this bug: 1485123
Yes, looks like a variant of Bug 1447775. I expect the artifacts are cleared when main window is resized, correct?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1447775
(Reporter)

Comment 3

8 months ago
(In reply to Martin Stránský [:stransky] from comment #2)
> Yes, looks like a variant of Bug 1447775. I expect the artifacts are cleared
> when main window is resized, correct?

Yes, the artifacts disappear when the window is resized.
The video attachment I included showed this, but I see now it is corrupted :(
You need to log in before you can comment on or make changes to this bug.