Closed Bug 1474586 Opened 4 years ago Closed 4 years ago

The content area context menu items “Copy Link Location” and “Copy Email Address” have different access keys, and it’s annoying: can we change the latter to match the former?

Categories

(Firefox :: Keyboard Navigation, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 63
Tracking Status
firefox63 --- fixed

People

(Reporter: me, Assigned: dao)

Details

Attachments

(1 file)

In the #contentAreaContextMenu, there are two very similar and mutually exclusively displayed items:

• #context-copyemail, label “Copy Email Address”, accesskey “E”;
• #context-copylink, label “Copy Link Location”, accesskey “a”.

I can’t tell you just *how many* times I’ve right clicked on an email address and pressed “a”, because I know that’s “copy the target of this link”¹, and then been briefly confused when it does nothing, before remembering that I’m dealing with an email link this time, and must use “e” instead.

I would therefore *really* like the #context-copyemail accesskey to be changed from “E” to “A” so that it matches #context-copylink.

I don’t suppose it’s readily possible to give a context menu two access keys? If not, I guess I’ll have a harder time convincing you that this change should happen. But I’ll try anyway: please?

----

¹ OK, so the target of the link would include a leading mailto:, but you know what I mean.
Copy Email Address and Copy Link Location are mutually exclusive, plus "A" works nicely for Copy Email Address, so I guess we should do this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Comment on attachment 8994182 [details]
Bug 1474586 - Change 'Copy Email Address' access key to A to match 'Copy Link Location'.

https://reviewboard.mozilla.org/r/258784/#review265670
Attachment #8994182 - Flags: review?(francesco.lodolo) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/954af89d16a8
Change 'Copy Email Address' access key to A to match 'Copy Link Location'. r=flod
https://hg.mozilla.org/mozilla-central/rev/954af89d16a8
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
You need to log in before you can comment on or make changes to this bug.