Closed Bug 1474621 Opened Last year Closed 6 months ago

defaultPlaybackRate fires ratechange event when it has not actually changed

Categories

(Core :: Audio/Video: Playback, defect, P3)

61 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: stefanprobst, Assigned: pehrsons)

References

()

Details

(Keywords: parity-chrome, parity-edge, testcase, Whiteboard: [qa-69b-p2])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180703192103

Steps to reproduce:

When setting defaultPlaybackRate on an HTML5 audio element to the value it already has, a `ratechange` event fires.

See: https://jsfiddle.net/hkqe7Ljv/


Actual results:

See above


Expected results:

No ratechange event should fire, since the value has not actually changed. This is the also the behaviour in Chrome.
Has STR: --- → yes
Component: Untriaged → Web Audio
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Component: Web Audio → Audio/Video: Playback
Status: UNCONFIRMED → NEW
Rank: 25
Ever confirmed: true
Priority: -- → P3
Assignee: nobody → apehrson
Status: NEW → ASSIGNED
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4900d67574d7
Ignore same values in SetDefaultPlaybackRate. r=jya
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Whiteboard: [qa-69b-p2]
You need to log in before you can comment on or make changes to this bug.