autocompletion text isn't displayed if there's at least one line after the cursor

RESOLVED WORKSFORME

Status

defect
P3
normal
RESOLVED WORKSFORME
11 months ago
9 months ago

People

(Reporter: nchevobbe, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

11 months ago
**Steps to reproduce**
1. Open the console
2. Paste the following: 

```js
function() {
  
}
```

3. Hit arrow up so the cursor is inside the function

```js
function() {
  |
}
```

4. Type `win`

**Expected results**

I expect the autocompletion text to be visible and show `dow` after `win`

**Actual results**

The autocompletion text is not displayed

---

This is because we only show the text if the cursor is at the end of the input [1], in order to not have it overlap with text that might come after. This is not quite the right strategy, as we should look if there is enough space on the line to display the autocomplete.


[1] https://searchfox.org/mozilla-central/rev/a80651653faa78fa4dfbd238d099c2aad1cec304/devtools/client/webconsole/components/JSTerm.js#1221-1225
Reporter

Updated

11 months ago
Depends on: 1463674
Priority: -- → P2
Whiteboard: [boogaloo-reserve]

Updated

11 months ago
Priority: P2 → P3
Reporter

Comment 1

9 months ago
STR from Comment 0 do show the completion text now. Probably fixed in Bug 1479521 .
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
Whiteboard: [boogaloo-reserve]
You need to log in before you can comment on or make changes to this bug.