Enable memory protection diagnostic on dev-edition.

RESOLVED FIXED in Firefox 62

Status

()

defect
P3
normal
RESOLVED FIXED
9 months ago
9 months ago

People

(Reporter: nbp, Assigned: nbp)

Tracking

unspecified
mozilla63
Points:
---

Firefox Tracking Flags

(firefox62 fixed, firefox63 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 months ago
Bug 1437600 added some instrumentation based on MOZ_DIAGNOSTIC_ASSERT_ENABLED macro, but the memory protection mechanism relies on RELEASE_OR_BETA to skip the memory protection handler.

For investigating, we need potentially more volume than only nightly, and as such we should disable the memory protection on release and beta, but not dev-edition (which is another kind of beta).

Thanks to Julien Cristau for figuring why we did not got reports on dev-edition.
(Assignee)

Updated

9 months ago
Priority: -- → P3
Comment on attachment 8991363 [details] [diff] [review]
Enable memory protection exception handler on dev-edition builds.

Review of attachment 8991363 [details] [diff] [review]:
-----------------------------------------------------------------

How popular is Dev Edition since the removal of the Aurora branch, out of curiosity? Either way, this looks fine. r=me
Attachment #8991363 - Flags: review?(emanuel.hoogeveen) → review+

Comment 3

9 months ago
Pushed by npierron@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/21f8f4c25486
Enable memory protection exception handler on dev-edition builds. r=ehoogeveen
(Assignee)

Comment 4

9 months ago
Comment on attachment 8991363 [details] [diff] [review]
Enable memory protection exception handler on dev-edition builds.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1437600
[User impact if declined]: This patch make crashes more actionable.
[Is this code covered by automated tests?]: yes.
[Has the fix been verified in Nightly?]: yes.
[Needs manual test from QE? If yes, steps to reproduce]:  no.
[List of other uplifts needed for the feature/fix]: none.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: Already running on nightly for 2/3 weeks.
[String changes made/needed]: None.
Attachment #8991363 - Flags: approval-mozilla-beta?

Comment 5

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/21f8f4c25486
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Comment on attachment 8991363 [details] [diff] [review]
Enable memory protection exception handler on dev-edition builds.

Looks like this will give us better diagnostic info on dev edition crashes, happy to take it. It should end up in 62.0b9.
Attachment #8991363 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Emanuel, FYI here is a way to get a rough idea of relative user volume on different channels. You can search crash-stats for crashes on a recent beta version (ie, 62.0b6) on the aurora channel. We do dev edition branded builds with various developer-friendly prefs, tools, or themes turned on, and release them on the update channel still named "aurora". The big difference is that we release them for a week before the first beta channel update, and then simultaneously with beta releases. It's a little odd because it's not a linear progress from nightly -> aurora -> beta. 

Here's an example search, https://crash-stats.mozilla.com/search/?release_channel=aurora&product=Firefox&version=62.0b6&date=%3E%3D2018-07-06T11%3A39%3A18.000Z&date=%3C2018-07-13T11%3A39%3A18.000Z&_sort=-date&_facets=signature&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-signature

Tweaking the "release channel" value to beta and comparing what's usually our top crash signature will show you that we have about an order of magnitude fewer Developer Edition users than Beta users.
Flags: needinfo?(emanuel.hoogeveen)
Thanks. I tried to compare Aurora to Nightly but the distribution of crashes is very different, probably due to Nightly generally being less stable than Aurora.
Flags: needinfo?(emanuel.hoogeveen)
You need to log in before you can comment on or make changes to this bug.