Closed Bug 1475054 Opened 2 years ago Closed 2 years ago

Tooltips for most address bar buttons are missing their background

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1474538
Tracking Status
firefox63 --- fixed

People

(Reporter: gerald, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

STR:
- Navigate to a page with dark background, e.g.: testpilot.firefox.com
- Hover mouse above one of the icons to the right of the address bar.

Expected:
Pop-up text should be clearly visible.
Ideally and for consistency, it should look like the one for tabs: Box with black border and light background, black text.

Actual:
Black text with some dark shadow, but no contrasting background, and because the text goes into the dark web page, it becomes unreadable.
See attached screenshot.

Interestingly, on the left side of the address bar, the first 3 buttons (backwards, forwards, reload) have "good" pop-ups (boxed, exactly like tabs), but the next ones (home, sidebar toggle) use the "bad" labels! Why the difference?


Seen in Nightly 63.0a1 (2018-07-11) on both Mac 10.13.5 and Windows 10 (didn't try Linux).
Can you find when this regressed? Tooltips should have a background.
Flags: needinfo?(gsquelart)
Summary: Pop-up labels for most address bar icons are unreadable when web page is dark → Tooltips for most address bar buttons are missing their background
Couldn't find a bad one through mozregression.
I've just updated Nightly (same version, so must be the 2nd 2018-07-11 build) and the problem has disappeared!

So "WFM". I'll reopen if I see it again.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(gsquelart)
Resolution: --- → WORKSFORME
Looks like this was a dupe of bug 1474538, which got resolved by backing out the regressor. :-)
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1474538
You need to log in before you can comment on or make changes to this bug.