Closed Bug 1475171 Opened 2 years ago Closed 2 years ago

Firefox 63 (nightly) freezes completely when clicking bash ftp download link

Categories

(Firefox :: Untriaged, defect)

63 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1467102

People

(Reporter: nissen, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180710222524

Steps to reproduce:

1. Go to https://tiswww.case.edu/php/chet/bash/bashtop.html
2. Under Current Status, first line of text saying "The current version of bash is bash-4.4. (GPG signature). ". Click the link: ftp://ftp.cwru.edu/pub/bash/bash-4.4.tar.gz


Actual results:

My entire Firefox completely freezes. All tabs. Firefox doesnt respond to mouse events anymore, and needs to be force closed.

Im running nightly (version 2018-07-10) on Linux with no cookies allowed and tracking protection enabled (I havent tried to allow cookies and disable tracking protection). It would be interesting to see if this  freeze happens to other people.


Expected results:

The file should download from the ftp server.
Im also using DoH and have set network.trr.mode to 3 (no fallback mode) so maybe that can also be a reason?

https://blog.nightly.mozilla.org/2018/06/01/improving-dns-privacy-in-firefox/
This seems to be duplication of  Bug 1467102. 
And it was fixed on Nightly(Build ID: 20180712092830)

@reporter,
could you test with latest Nightly?
Flags: needinfo?(nissen)
Yes, It works now in latest nightly!

Fastest bugfix I have ever experienced! Sorry for the duplicate. Great job guys. :)
Flags: needinfo?(nissen)
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1467102
You need to log in before you can comment on or make changes to this bug.