window.innerHeight never reports less than 150px

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: Martin Jacobs, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows ME
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052306
screen resolution is 800x600 

When opening or resizing a window with less than 150px innerheight,
window.innerHeight property always reports 150px.  
Outer dimensions (outerHeight, outerWidth) are OK.  
(besides innerWidth can't shrink to less than 104px)  

attaching reduced test case 

Reproducible: Always
Steps to Reproduce:
1. open an empty window with "innerHeight=100,innerWidth=100"
   window.innerHeight is 150px (wrong)
2. resize it to (100,100) 
   window.innerHeight reports 150px too
3. resize to (200,200) 
   window.innerHeight is 172 (correct) 

Actual Results:  see attached test case 

Expected Results:  window dimensions from 100px to 150px are allowed and this
property should give actual measurement.
(Reporter)

Comment 1

16 years ago
Created attachment 85224 [details]
reduced test case

Comment 2

16 years ago
I get wndw is undefined on the testcase. Line 7
(Reporter)

Comment 3

16 years ago
Created attachment 85247 [details]
improved test case

improved reduced test case (obsoletes #85224) 
waiting for wndw opening and loading.

Comment 4

16 years ago
Eh... I still get javascript errors. Check the console

Comment 5

16 years ago
Sorry, i am an idiot. I had "open unrequested windows" unchecked.
(Reporter)

Comment 6

16 years ago
Is there a way to check for this preference ?   
Not w/o trying to open a window, but if you try to open a window and
window.open() returns null, then you'll know that opening windows is not allowed
in the client.
(Reporter)

Comment 8

16 years ago
Right. Thanks. 
I see this on Windows as well....
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 10

16 years ago
Created attachment 85421 [details]
varying window sizes

This test is more self-explanatory.  (obsoletes #85247) 
Change height and/or width manually to get inner/outer values.	
OnResize event is buggy too below 150px height.  
Click on 'get sizes' to refresh outerHeight.
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs

Updated

14 years ago
Attachment #85224 - Attachment is obsolete: true

Updated

14 years ago
Keywords: testcase

Comment 12

13 years ago
Why has this bug not been fixed?

Comment 13

13 years ago
*** Bug 282468 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b) Gecko/20050216
Firefox/1.0+

Can anyone verify that this work on trunk?

Comment 15

13 years ago
WFM with Mozilla 1.8b build 2005021614 on WinNT4.

Comment 16

13 years ago
Marking as such, please reopen if you can reproduce with a nightly build.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 282468
You need to log in before you can comment on or make changes to this bug.