Closed Bug 1475215 Opened 2 years ago Closed 2 years ago

Default Firefox Nightly theme becomes a dark theme after switching in customize panel

Categories

(Firefox :: Toolbars and Customization, defect, P1)

63 Branch
x86_64
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1474591
Tracking Status
firefox62 --- unaffected
firefox63 - affected

People

(Reporter: Gadzillos, Unassigned)

Details

Attachments

(1 file)

Default FirefoxNightly (63.0a1 2018-07-11) theme becomes a dark theme after switching in customize panel
I can't choose the default Firefox Nightly theme even if I restore default settings in customize panel.
[Tracking Requested - why for this release]: new feature in 63 (introduced by bug 1368808), we should make sure that we fix any confusion around it before it gets released.

Gadzillos, do you have Windows set to use a dark theme? This is enabled by going to the Personalize -> Colors -> Choose your default app mode and choosing Dark.

This is most likely from bug 1368808. In my testing of this, we show a preview of the Default (light on dark) theme when hovering over the Default item within Customize mode but clicking on it will use the Dark theme.

We shouldn't be showing the "light on dark" default theme during the preview, and possibly we may want to add some kind of string that says that the Default theme is using Dark based on system preferences.
Blocks: 1368808
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(Gadzillos)
Priority: -- → P1
shorlander, what do you think about adding a string like I proposed in comment 1? I'm not sure where it would fit.
Flags: needinfo?(shorlander)
This appears to be the same as bug 1474591. Let's not spread the discussion across multiple bugs.
No longer blocks: 1368808
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(shorlander)
Flags: needinfo?(Gadzillos)
Resolution: --- → DUPLICATE
Duplicate of bug: 1474591
Not tracking this one as we already track bug 1474591 for 63
You need to log in before you can comment on or make changes to this bug.