Closed Bug 1475251 Opened 2 years ago Closed 2 years ago

HTTP auth dialog looks wrong

Categories

(Firefox for Android :: General, defect)

Firefox 63
All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- verified
firefox63 + verified

People

(Reporter: kats, Assigned: petru)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

The HTTP auth dialog in Fennec has regressed sometime in the last few days. The username/password fields are one character wide now, instead of the width of the dialog. See attached screenshot. You can make one of these appear by going to https://bugmash.staktrace.com/dashboard.php
Keywords: regression
Version: 57 Branch → Firefox 63
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=84683bf540a58f9d3db645550748e37c742991d6&tochange=5c13bf70a3e1bac455d93c136d8079ac3be022e9
Blocks: 1412517
Has Regression Range: --- → yes
Flags: needinfo?(petru.lingurar)
OS: Unspecified → Android
Hardware: Unspecified → All
Thanks Jan!

Indeed seems to be a regression caused by bug 1412517.
The easiest solution would be an instanceof check for the PromptInputs but I'll look for something better.
Flags: needinfo?(petru.lingurar)
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Attachment #8992279 - Flags: review?(sdaswani) → review?(nchen)
Comment on attachment 8992279 [details]
Bug 1475251 - HTTP auth dialog looks wrong;

https://reviewboard.mozilla.org/r/257164/#review264178
Attachment #8992279 - Flags: review?(nchen) → review+
Keywords: checkin-needed
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/02eefb5f33de
HTTP auth dialog looks wrong; r=jchen
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/02eefb5f33de
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1477694
Bug 1412517 wasn't uplifted to Beta, so it should be unaffected, shouldn't it?
Current beta (62.0b9) indeed looks unaffected on my device.
Flags: qe-verify+
Verified in the latest Nightly and everything works as expected.
Flags: qe-verify+
Comment on attachment 8992279 [details]
Bug 1475251 - HTTP auth dialog looks wrong;

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1412517
[User impact if declined]: The widget to allow entering text in input pickers only shows one character, it does not expand the full line making this process cumbersome.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: --
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: No
[Why is the change risky/not risky?]: Has been QE verified and in the time being in Nightly no issues have been reported.
[String changes made/needed]: --
Attachment #8992279 - Flags: approval-mozilla-beta?
Comment on attachment 8992279 [details]
Bug 1475251 - HTTP auth dialog looks wrong;

One of several small fixes for the date picker related to the switch in 62 to using the platform library. Verified in nightly. 
Let's uplift for next Monday's beta 17 build.
Attachment #8992279 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
Can you please check this, Levente?
Flags: needinfo?(levente.sacal)
Verified as fixed in 62 Beta 17. Working as expected on Sony Xperia Z5 (Android 7.0) & Samsung S8+ (Android 8.0.0)
Flags: needinfo?(levente.sacal)
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.