Closed Bug 1475612 Opened 3 years ago Closed 3 years ago

LSBUtils double closes a file descriptor on a background thread

Categories

(Core :: Widget, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: kmag, Assigned: kmag)

References

Details

Attachments

(1 file)

LSBUtils calls close on a file descriptor that it has already closed with fclose. And since it does this on a background thread, it races with code that opens files on the main thread, and leads to weird breakage.
Comment on attachment 8991980 [details]
Bug 1475612: Fix double file close on background thread.

https://reviewboard.mozilla.org/r/256882/#review263774
Attachment #8991980 - Flags: review?(erahm) → review+
Duplicate of this bug: 1475588
https://hg.mozilla.org/mozilla-central/rev/a299ae02fc4c
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Duplicate of this bug: 1475696
Duplicate of this bug: 1475663
Duplicate of this bug: 1475140
You need to log in before you can comment on or make changes to this bug.