Closed Bug 1475644 Opened 2 years ago Closed 2 years ago

Don't send URL in GeckoView crashes

Categories

(GeckoView :: General, defect)

59 Branch
defect
Not set

Tracking

(firefox-esr52 wontfix, firefox-esr60 wontfix, firefox61 wontfix, firefox62 fixed, firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- wontfix
firefox-esr60 --- wontfix
firefox61 --- wontfix
firefox62 --- fixed
firefox63 --- fixed

People

(Reporter: snorp, Assigned: snorp)

Details

(Whiteboard: [geckoview:klar:p1])

Attachments

(1 file)

We're accidentally doing this right now.
Comment on attachment 8992000 [details]
Bug 1475644 - Don't send URL in GeckoView crash reports

https://reviewboard.mozilla.org/r/256890/#review263790
Attachment #8992000 - Flags: review?(nchen) → review+
Assignee: nobody → snorp
Whiteboard: [geckoview:klar:p1]
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/449887ba75e3
Don't send URL in GeckoView crash reports r=jchen
https://hg.mozilla.org/mozilla-central/rev/449887ba75e3
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
Comment on attachment 8992000 [details]
Bug 1475644 - Don't send URL in GeckoView crash reports

Approval Request Comment
[Feature/Bug causing the regression]: This is old code.
[User impact if declined]: Focus+GeckoView's crash reports will include users' URLs. The crash reports still do include other potential PII like memory dumps.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: The fix landed on GV Nightly two days ago, but it has not been manually tested by QA or Focus Nightly.
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Not risky because it is a tiny patch and only affects GeckoView code, not Fennec.
[String changes made/needed]: None
Attachment #8992000 - Flags: approval-mozilla-beta?
Comment on attachment 8992000 [details]
Bug 1475644 - Don't send URL in GeckoView crash reports

Privacy fix for geckoview, let's get this into beta 10.
Attachment #8992000 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
James, why did we stop including URLs in GV crash reports when we include them in desktop crash reports? Because GV crash reporting was enabled by default?
Flags: needinfo?(snorp)
(In reply to Chris Peterson [:cpeterson] from comment #8)
> James, why did we stop including URLs in GV crash reports when we include
> them in desktop crash reports? Because GV crash reporting was enabled by
> default?

Do we send them in desktop reports? In Fennec it has always been opt-in.

And yes, GV crash reporting is enabled by default in Focus. We could add URLs in some opt-in "enhanced" bug reporting, maybe?
Flags: needinfo?(snorp)
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #9)
> Do we send them in desktop reports? In Fennec it has always been opt-in.

Desktop reports do include URLs, but desktop Firefox also prompts the user before submitting each report. Basic crash report info are visible to anyone browsing crash-stats.m.o, but the URLs and memory dumps are only available for users with special crash-stats permissions.

> And yes, GV crash reporting is enabled by default in Focus. We could add
> URLs in some opt-in "enhanced" bug reporting, maybe?

I'm working with the Mozilla Data Stewards (in bug 1480260) to review our default settings now that we have both Sentry and Breakpad/Socorro crash reports. Sentry does not include PII, but Breakpad includes stack memory which might contain PII.
Product: Firefox for Android → GeckoView
Version: Firefox 59 → 59 Branch
Target Milestone: Firefox 63 → mozilla63
You need to log in before you can comment on or make changes to this bug.