Closed Bug 1475799 Opened 2 years ago Closed 2 years ago

Change add-ons location in SeaMonkey to addons.thunderbird.net and clean up references to mozilla.org

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.57 Branch
defect
Not set

Tracking

(seamonkey2.49esr fixed, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.60 fixed)

RESOLVED FIXED
seamonkey2.60
Tracking Status
seamonkey2.49esr --- fixed
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.60 --- fixed

People

(Reporter: frg, Assigned: frg)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Keywords: late-l10n)

Attachments

(3 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1475151 +++

addons.mozilla.org needs to be switched to addons.thunderbird.net in the source, default bookmarks and preferences.

Currently I am not sure how this affects 2.49.x so lets deal with this later.
Attached patch 1475799-addonsbookmarks.patch (obsolete) — Splinter Review
This will probably need other changes for the V3 add-on api now used by amo and Thunderbird.net. We will find out later.
Attached image Capture.PNG
The patch seems to do the trick.

Installed complete theme, dictionary, add-on and a lightweight theme (this one does not work yet in 2.57 because of other problems).

Test version including the patch can be found here:

http://www.wg9s.com/comm-257/
Comment on attachment 8992163 [details] [diff] [review]
1475799-addonsbookmarks.patch

This also switches the en-US bookmarks to https whenever possible and removes no longer relevant mozilla.org bookmarks.

search.placeholder2 hardcodes mozilla.org. Nothing we can do here for now.

https://dxr.mozilla.org/comm-central/source/mozilla/toolkit/locales/en-US/chrome/mozapps/extensions/extensions.dtd#6
Attachment #8992163 - Flags: review?(iann_bugzilla)
Attachment #8992163 - Flags: approval-comm-esr60?
Some webextension prtefs and the TB default theme crept in. Fixed.
Attachment #8992163 - Attachment is obsolete: true
Attachment #8992163 - Flags: review?(iann_bugzilla)
Attachment #8992163 - Flags: approval-comm-esr60?
Attachment #8992522 - Flags: review?
Attachment #8992522 - Flags: approval-comm-esr60?
Comment on attachment 8992522 [details] [diff] [review]
1475799-addonsbookmarks.patch

LGTM r/a=me#
Should we also include Bug 1476172 - Add channel argument to app.releaseNotesURL?
Flags: needinfo?(frgrahl)
Attachment #8992522 - Flags: review?
Attachment #8992522 - Flags: review+
Attachment #8992522 - Flags: approval-comm-esr60?
Attachment #8992522 - Flags: approval-comm-esr60+
> Should we also include Bug 1476172 - Add channel argument to app.releaseNotesURL?

I think this would need changes to the website and probably all distinct sites like seamonkey.at in the l10n repos. So I would pass for now and maybe look at it again at the time for the 2.57 release. Update url might need changes also then. So far the channel is imho picked using the version and we just match this one either generic (a*) or distict 2.48b1 to show the start page.
Flags: needinfo?(frgrahl)
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/a712d22c0257
Change add-ons location in SeaMonkey to addons.thunderbird.net and clean up default bookmarks and other references. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
https://hg.mozilla.org/releases/comm-esr60/rev/4282e7fc9c2b3c1f9fe63aaaad8d26f684195628

TB does not plan to fix it for TB 52. Currently this causes no problem because mozilla.org redirects to thunderbird.net. I am setting affected for SeaMonkey 2.49 because we probably need to support this release a while longer.

See
https://github.com/mozilla/addons-server/issues/6390#issuecomment-392942905
for the redirect rules.
Target Milestone: --- → seamonkey2.60
Comment on attachment 8992522 [details] [diff] [review]
1475799-addonsbookmarks.patch

Review of attachment 8992522 [details] [diff] [review]:
-----------------------------------------------------------------

::: suite/locales/en-US/chrome/mailnews/start.dtd
@@ +24,5 @@
>  <!--# LOCALIZATION NOTE (dict_info.label): the URL for <a id="dictURL"> is fetched from brand.properties -->
>  <!ENTITY dict_info.label
>  'Many additional languages can be installed from the
>  <a id="dictURL" href="">dictionaries</a> section on
> +<a href="https://addons.thunderbird.net/seamonkey/">SeaMonkey and Thunderbird Add-ons</a>.'>

Typically doing changes to l10n stuff, when substantive, needs a new entity name (e.g. dict_info2.label) and the associated code to update for it.

As it stands just updating this won't directly flag a localizer to translate it to the new URL or text.
Thanks Callek, you are right.

I checked all distributed l10n languages and not one uses a custom addons site. I don't think one ever will or that this will currently make sense so I moved this directly to the prefs file like in TB.

de and ru use specific release notes or vendor urls.

That left only dict_info.label for l10n.
Attachment #8993702 - Flags: review?(iann_bugzilla)
Attachment #8993702 - Flags: approval-comm-esr60?
Comment on attachment 8993702 [details] [diff] [review]
1475799-staticprefs.patch

LGTM r/a=me

Localisers should pick up the removal but might be worth posting a note about it
Attachment #8993702 - Flags: review?(iann_bugzilla)
Attachment #8993702 - Flags: review+
Attachment #8993702 - Flags: approval-comm-esr60?
Attachment #8993702 - Flags: approval-comm-esr60+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/07e930aae6f2
Follow-up: Move preferences not used by localizers from branding to prefs and update l10n tags. r=IanN
https://hg.mozilla.org/releases/comm-esr60/rev/905d670c44de
Follow-up: Move preferences not used by localizers from branding to prefs and update l10n tags. r=IanN a=IanN

Let me think about a general localizer note for esr60 2.57. Will not be the last one.
Keywords: late-l10n
Blocks: 1484479
Duplicate of this bug: 1475809
Blocks: 1554929
You need to log in before you can comment on or make changes to this bug.