Closed Bug 1475812 Opened 2 years ago Closed 1 year ago

Intermittent dom/canvas/test/webgl-conf/generated/<test_name> | successfullyParsed should be true (of type boolean). Was undefined (of type undefined).

Categories

(Core :: Canvas: WebGL, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure, Whiteboard: [TV-bf nowfound])

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=188071194&repo=mozilla-beta

https://queue.taskcluster.net/v1/task/EnSLSrQMRuW9PdthZJS1BA/runs/0/artifacts/public/logs/live_backing.log

09:28:38     INFO - TEST-START | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-in-loop.html
09:28:38     INFO - GECKO(1896) | JavaScript error: http://mochi.test:8888/tests/dom/canvas/test/webgl-conf/checkout/js/webgl-test-utils.js, line 2009: SyntaxError: illegal character
09:28:38     INFO - TEST-INFO | started process screencapture
09:28:38     INFO - TEST-INFO | screencapture: exit 0
09:28:38     INFO - Buffered messages logged at 09:28:38
09:28:38     INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-in-loop.html | A valid string reason is expected 
09:28:38     INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-in-loop.html | Reason cannot be empty 
09:28:38     INFO - Buffered messages finished
09:28:38     INFO - TEST-UNEXPECTED-FAIL | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-in-loop.html | successfullyParsed should be true (of type boolean). Was undefined (of type undefined). 
09:28:38     INFO -     reportResults@dom/canvas/test/webgl-conf/mochi-single.html?checkout/conformance/glsl/bugs/conditional-discard-in-loop.html:22:7
09:28:38     INFO -     reportTestResultsToHarness@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:116:5
09:28:38     INFO -     testFailed@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:246:5
09:28:38     INFO -     shouldBe@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:403:9
09:28:38     INFO -     shouldBeTrue@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:429:29
09:28:38     INFO -     @dom/canvas/test/webgl-conf/checkout/js/js-test-post.js:24:1
09:28:38     INFO - GECKO(1896) | MEMORY STAT | vsize 4637MB | residentFast 507MB | heapAllocated 168MB
09:28:38     INFO - TEST-OK | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-in-loop.html | took 208ms
09:28:38     INFO - TEST-START | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-optimization.html
09:28:38     INFO - GECKO(1896) | JavaScript error: http://mochi.test:8888/tests/dom/canvas/test/webgl-conf/checkout/js/webgl-test-utils.js, line 2009: SyntaxError: illegal character
09:28:38     INFO - Not taking screenshot here: see the one that was previously logged
09:28:38     INFO - Buffered messages logged at 09:28:38
09:28:38     INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-optimization.html | A valid string reason is expected 
09:28:38     INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-optimization.html | Reason cannot be empty 
09:28:38     INFO - Buffered messages finished
09:28:38     INFO - TEST-UNEXPECTED-FAIL | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-optimization.html | successfullyParsed should be true (of type boolean). Was undefined (of type undefined). 
09:28:38     INFO -     reportResults@dom/canvas/test/webgl-conf/mochi-single.html?checkout/conformance/glsl/bugs/conditional-discard-optimization.html:22:7
09:28:38     INFO -     reportTestResultsToHarness@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:116:5
09:28:38     INFO -     testFailed@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:246:5
09:28:38     INFO -     shouldBe@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:403:9
09:28:38     INFO -     shouldBeTrue@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:429:29
09:28:38     INFO -     @dom/canvas/test/webgl-conf/checkout/js/js-test-post.js:24:1
09:28:38     INFO - GECKO(1896) | MEMORY STAT | vsize 4643MB | residentFast 507MB | heapAllocated 167MB
09:28:38     INFO - TEST-OK | dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-optimization.html | took 227ms
Summary: Intermittent dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-in-loop.html | successfullyParsed should be true (of type boolean). Was undefined (of type undefined). → Intermittent dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-in-loop.html | successfullyParsed should be true (of type boolean). Was undefined (of type undefined). (mozilla-beta)
Whiteboard: [TV-bf notfound]
Summary: Intermittent dom/canvas/test/webgl-conf/generated/test_conformance__glsl__bugs__conditional-discard-in-loop.html | successfullyParsed should be true (of type boolean). Was undefined (of type undefined). (mozilla-beta) → Intermittent dom/canvas/test/webgl-conf/generated/test_conformance__* | successfullyParsed should be true (of type boolean). Was undefined (of type undefined). (mozilla-beta)
Summary: Intermittent dom/canvas/test/webgl-conf/generated/test_conformance__* | successfullyParsed should be true (of type boolean). Was undefined (of type undefined). (mozilla-beta) → Intermittent dom/canvas/test/webgl-conf/generated/test_conformance__* | successfullyParsed should be true (of type boolean). Was undefined (of type undefined).
Duplicate of this bug: 1459494
Duplicate of this bug: 1459694
Duplicate of this bug: 1471005
Duplicate of this bug: 1471482
Duplicate of this bug: 1471858
Duplicate of this bug: 1472217
Duplicate of this bug: 1472959
Duplicate of this bug: 1474305
Duplicate of this bug: 1474615
Duplicate of this bug: 1474867
Duplicate of this bug: 1475667
Duplicate of this bug: 1480463
Duplicate of this bug: 1470598
These tests can now be backfilled on current revisions.

https://treeherder.mozilla.org/logviewer.html#?job_id=193951206&repo=try
Whiteboard: [TV-bf notfound] → [TV-bf nowfound]
https://wiki.mozilla.org/Bug_Triage#Intermittent_Test_Failure_Cleanup
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Duplicate of this bug: 1504919
Duplicate of this bug: 1504322
Duplicate of this bug: 1501969
Duplicate of this bug: 1501468
Duplicate of this bug: 1499143
Duplicate of this bug: 1493213
Duplicate of this bug: 1482686
Duplicate of this bug: 1488201
Duplicate of this bug: 1509704
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Duplicate of this bug: 1540452
Duplicate of this bug: 1539743
Duplicate of this bug: 1538682
Duplicate of this bug: 1458099
Duplicate of this bug: 1463188
Duplicate of this bug: 1541712
Duplicate of this bug: 1541745
Duplicate of this bug: 1543532
Duplicate of this bug: 1547609
Duplicate of this bug: 1556006
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → INCOMPLETE

Recent log failure: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=258375339&repo=autoland&lineNumber=2493

[task 2019-07-25T20:56:12.011Z] 20:56:12 INFO - TEST-START | dom/canvas/test/webgl-conf/generated/test_conformance__limits__gl-max-texture-dimensions.html
[task 2019-07-25T20:57:14.650Z] 20:57:14 INFO - GECKO(1645) | JavaScript error: http://mochi.test:8888/tests/dom/canvas/test/webgl-conf/checkout/conformance/limits/gl-max-texture-dimensions.html, line 64: ReferenceError: WebGLTestUtils is not defined
[task 2019-07-25T20:57:15.712Z] 20:57:15 INFO - TEST-INFO | started process screencapture
[task 2019-07-25T20:57:16.011Z] 20:57:16 INFO - TEST-INFO | screencapture: exit 0
[task 2019-07-25T20:57:16.012Z] 20:57:16 INFO - Buffered messages logged at 20:56:12
[task 2019-07-25T20:57:16.012Z] 20:57:16 INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_conformance__limits__gl-max-texture-dimensions.html | A valid string reason is expected
[task 2019-07-25T20:57:16.012Z] 20:57:16 INFO - TEST-PASS | dom/canvas/test/webgl-conf/generated/test_conformance__limits__gl-max-texture-dimensions.html | Reason cannot be empty
[task 2019-07-25T20:57:16.013Z] 20:57:16 INFO - Buffered messages finished
[task 2019-07-25T20:57:16.013Z] 20:57:16 INFO - TEST-UNEXPECTED-FAIL | dom/canvas/test/webgl-conf/generated/test_conformance__limits__gl-max-texture-dimensions.html | successfullyParsed should be true (of type boolean). Was undefined (of type undefined).
[task 2019-07-25T20:57:16.013Z] 20:57:16 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
[task 2019-07-25T20:57:16.013Z] 20:57:16 INFO - reportResults@dom/canvas/test/webgl-conf/mochi-single.html?checkout/conformance/limits/gl-max-texture-dimensions.html:22:14
[task 2019-07-25T20:57:16.013Z] 20:57:16 INFO - reportTestResultsToHarness@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:111:36
[task 2019-07-25T20:57:16.013Z] 20:57:16 INFO - testFailed@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:241:5
[task 2019-07-25T20:57:16.014Z] 20:57:16 INFO - shouldBe@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:408:9
[task 2019-07-25T20:57:16.014Z] 20:57:16 INFO - shouldBeTrue@dom/canvas/test/webgl-conf/checkout/js/js-test-pre.js:434:29
[task 2019-07-25T20:57:16.014Z] 20:57:16 INFO - @dom/canvas/test/webgl-conf/checkout/js/js-test-post.js:24:1
[task 2019-07-25T20:57:16.014Z] 20:57:16 INFO - GECKO(1645) | MEMORY STAT | vsize 7651MB | residentFast 132MB | heapAllocated 81MB

Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Summary: Intermittent dom/canvas/test/webgl-conf/generated/test_conformance__* | successfullyParsed should be true (of type boolean). Was undefined (of type undefined). → Intermittent dom/canvas/test/webgl-conf/generated/<test_name> | successfullyParsed should be true (of type boolean). Was undefined (of type undefined).
Duplicate of this bug: 1568807
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Flags: needinfo?(jgilbert)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.