Closed Bug 1475816 Opened 3 years ago Closed 3 years ago

Some fields in prefs look ugly

Categories

(Thunderbird :: Theme, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 63.0

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

Attachments

(2 files)

M-C changed how toolkit stylesheets are loaded. Now they are loaded as Document stylesheet and no more with xul.css. This makes them load later in the chain and sometimes the specificy is now higher than our. It it also a bit different to FX as they load the prefs as document and we as chrome (it could also be vice versa, I'm not sure).
This makes the prefs look like before.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8992174 - Flags: review?(jorgk)
Which fields look ugly? Do I need to be on M-C tip to see it?
The captions of groupboxes for example in Advanced and the textboxes on Linux and Mac have lost their border. Tho see all you need to be on tip, but the captions are already visible on the latest Daily.

I've added already code for richlistboxes which we will use with bug 1475817 to still look like the listboxes we use now.
Looks like I'll need to rebuild. Right now, I'm using a top of the range i7-powered laptop which is still 2-3 times slower then my Ryzen.
I have a fresh build now. "Captions of group boxes for example in Advanced", sorry I can't see anything bad. Which theme? Please attach a screenshot so I know what I'm looking for.
I can't see anything ugly in the screenshot. In my local build those captions/headers look fine and they look the same without and with the patch. I've tried with default and dark theme. I can't judge the Mac/Linux changes.
The captions have a different background color than the whole window. Ugly may be the wrong description, Would wrong be better?
The prefs aren't styled by the Dark/Light themes.
(In reply to Richard Marti (:Paenglab) from comment #8)
> The captions have a different background color than the whole window.
I can't see that. Is that meant to be visible in the screenshot?

> The prefs aren't styled by the Dark/Light themes.
So what do I do to see the ugly/wrong/bad state that is fixed by the patch?
(In reply to Jorg K (GMT+2) from comment #9)
> (In reply to Richard Marti (:Paenglab) from comment #8)
> > The captions have a different background color than the whole window.
> I can't see that. Is that meant to be visible in the screenshot?

Then your monitor does not show this difference. The prefs background is #f9f9fa and the caption background is #ffffff

> > The prefs aren't styled by the Dark/Light themes.
> So what do I do to see the ugly/wrong/bad state that is fixed by the patch?

You could add this to userChrome.css:

#MailPreferences {
  background-color: red !important;
}

Without the patch the background is red and the caption background white. With patch the caption background is red too because the background is transparent.
Comment on attachment 8992174 [details] [diff] [review]
StylesheetOverrides.patch

(In reply to Richard Marti (:Paenglab) from comment #10)
> Then your monitor does not show this difference. The prefs background is
> #f9f9fa and the caption background is #ffffff
I can't see this, can you? Anyway, confirmed with GIMP.
Attachment #8992174 - Flags: review?(jorgk) → review+
Yes, I can see it, otherwise I wouldn't fix it.
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/6d0085e0dd11
Style overrides after loading of toolkit stylesheets as document stylesheets. r=jorgk
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0
You need to log in before you can comment on or make changes to this bug.