Closed Bug 1475916 Opened 3 years ago Closed 3 years ago

Only 4 rows are displayed in the profile manager

Categories

(Toolkit :: Startup and Profile System, defect)

63 Branch
Unspecified
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 - fixed

People

(Reporter: alice0775, Assigned: Paolo)

References

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

[Tracking Requested - why for this release]: Regression of usability

Steps To Reproduce:
1. Start Firefox.exe -p

Actual Results:
only 4 rows.
It is slightly difficult to choice a profile because too few rows are displayed at a time.

Expected Results:
At least, 5 rows like previous version


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a34a6f54da753e87e778e477f2760753ebf519b6&tochange=bd281782dc93474944f6a9375312e7e3a31cd061

Regressed by: 0b45728b7210	Paolo Amadini — Bug 1472750 - Convert simple "listbox" instances to "richlistbox". r=bgrins
Paolo, it seems that your patch in Bug 1472750 caused this regression, could you have a look please? Thanks
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(paolo.mozmail)
I'm not too concerned about the exact height of this list, but it makes sense to set the height using em to keep into account desktop font scaling. I've also given the list a few more rows on average.
Flags: needinfo?(paolo.mozmail)
(In reply to :Paolo Amadini from comment #3)
> I'm not too concerned about the exact height of this list, but it makes
> sense to set the height using em to keep into account desktop font scaling.
> I've also given the list a few more rows on average.

There will be a similar issue for any listbox that got converted richlistbox and set [height] in the markup, right? Or is there something different about ones that have theme-listbox applied?
(In reply to Brian Grinstead [:bgrins] from comment #4)
> There will be a similar issue for any listbox that got converted richlistbox
> and set [height] in the markup, right?

Right, it looks like the one in "languages.xul" can also be converted to use "em".
Comment on attachment 8993654 [details]
Bug 1475916 - Use em instead of px for list heights to keep font scaling into account.

https://reviewboard.mozilla.org/r/258342/#review265698
Attachment #8993654 - Flags: review?(bgrinstead) → review+
Pushed by paolo.mozmail@amadzone.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ada757eb3b82
Use em instead of px for list heights to keep font scaling into account. r=bgrins
https://hg.mozilla.org/mozilla-central/rev/ada757eb3b82
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee: nobody → paolo.mozmail
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.