Closed Bug 1475967 Opened Last year Closed Last year

Hovering the horizontal border above "Previous conversations" in Chat to move it vertically shows horizontal arrows instead of vertical arrows

Categories

(Thunderbird :: Theme, defect)

defect
Not set

Tracking

(thunderbird_esr6063+ fixed, thunderbird63 wontfix, thunderbird64 fixed)

VERIFIED FIXED
Thunderbird 64.0
Tracking Status
thunderbird_esr60 63+ fixed
thunderbird63 --- wontfix
thunderbird64 --- fixed

People

(Reporter: jorgk, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(3 files)

Hovering the horizontal border above "Previous conversations" in Chat to move it vertically shows horizontal arrows instead of vertical errors.

Working in TB 52, not working in TB 60 and Daily.
Summary: Hovering the horizontal border above "Previous conversations" in Chat to move it vertically shows horizontal arrows instead of vertical errors → Hovering the horizontal border above "Previous conversations" in Chat to move it vertically shows horizontal arrows instead of vertical arrows
This is very weird. When I open the DevTools Inspector, the arrows change to the correct ones. They are <splitter orient="vertical"> like others but behave different. And I don't know why.
While filing bug 1494394 i stumbled upon this one and I think the splitter with id logsSplitter need a horizontal orientation in order to get a vertical pointer:
https://dxr.mozilla.org/comm-central/source/comm/mail/components/im/content/chat-messenger.inc#178
Does that help, Richard?
Flags: needinfo?(richard.marti)
Yes, this fixes it for me. For beta too?
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #9015007 - Flags: review?(jorgk)
Attachment #9015007 - Flags: approval-comm-beta?
And for ESR?
Attachment #9015008 - Flags: approval-comm-esr60?
Comment on attachment 9015007 [details] [diff] [review]
1475967-splitter.patch

Works for me, thanks. What is the change in imconversation.xml for?
Attachment #9015007 - Flags: review?(jorgk)
Attachment #9015007 - Flags: review+
Attachment #9015007 - Flags: approval-comm-beta?
Attachment #9015007 - Flags: approval-comm-beta+
Oh, I see, one is for the history, one for the current conversation. Stand-by for landing.
Attachment #9015008 - Flags: approval-comm-esr60? → approval-comm-esr60+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/b9dada9b780c
Set orient="vertical" by default to the vertical Chat splitters. r=jorgk DONTBUILD
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 64.0
Mid-air-collision after mid-air-collision. ;)

(In reply to Jorg K (GMT+2) from comment #7)
> Oh, I see, one is for the history, one for the current conversation.
> Stand-by for landing.

Correct, I saw there sometimes also the wrong cursor.
(In reply to Jorg K (GMT+2) from comment #6)
> Comment on attachment 9015007 [details] [diff] [review]
> 1475967-splitter.patch
> 
> Works for me, thanks. What is the change in imconversation.xml for?

That one was probably for bug 1494394
Duplicate of this bug: 1494394
Confirmed working in ESR build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.