No dialog when prefs set to ask about cookies

VERIFIED FIXED in Chimera0.3

Status

Camino Graveyard
Preferences
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Jeremy Beker, Assigned: Brade)

Tracking

unspecified
Chimera0.3
PowerPC
Mac OS X

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
Description just about says it all.  Just downloaded 0.28 and was excited to see
the cookie prefs, but they don't seem to work.

(OS 10.1 5Q125)

-Jeremy

Comment 1

16 years ago
changing summary from "Checking 'ask about all cookies' does nothing" to "Cookie
preferences need enabled"

'Ask me before storing a cookie' and 'Disable cookies' radio button do not work

06/06/02 trunk
Component: General → Preferences
Summary: Checking "ask about all cookies" does nothing → Cookie preferences need enabled

Comment 2

16 years ago
->pink, this is done right? Or is this something waiting on other changes?
Assignee: saari → pinkerton
can you give me a testcase?
Status: NEW → ASSIGNED
Target Milestone: --- → Chimera0.3
(Reporter)

Comment 4

16 years ago
Here is my test.  

1. I downloaded the daily build today (6/17)
2. I deleted my .mozilla directory
3. Started Chimera
4. Set my "privacy prefs" to be "Accept all cookies" and "Ask me before storing
a cookie"
5. Visited www.slashdot.org (no cookie questions asked)
6. Logged in to slashdot (no cookie questions asked)
7. Quit Chimera
8.  Looked at my cookies.txt file in my .mozilla directory, and there were two
cookies stored.

So Chimera is obviously not asking me pror to storing those cookies.
(Assignee)

Comment 5

16 years ago
pink--can I have this one?  :-)
(Assignee)

Comment 6

16 years ago
grabbing
Assignee: pinkerton → brade
Status: ASSIGNED → NEW
(Assignee)

Comment 7

16 years ago
Created attachment 88134 [details] [diff] [review]
implement confirmex

reviews please
Summary: Cookie preferences need enabled → No dialog when prefs set to ask about cookies
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

16 years ago
Comment on attachment 88134 [details] [diff] [review]
implement confirmex

needs to use localized strings from properties file instead of hard-coding
Attachment #88134 - Attachment is obsolete: true
(Assignee)

Comment 9

16 years ago
Created attachment 88171 [details] [diff] [review]
patch that uses localized strings

reviews?
fixed. not only was confirmex not implemented, but I was using the wrong pref
name for enabling/disabling cookies. sigh.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 11

16 years ago
Verified using 06-21 build on OS 10.1.5.

Test steps:
1.  Went to Privacy preferences panel.
2.  Selected "Enable all cookies", and checked "Ask me before storing a cookie."
3.  Clicked "Clear stored cookies". (although it didn't look like it did anything)
4.  Closed prefs panel.
5.  Quit chimera.
6.  Relaunched chimera.
7.  Went to the bugzilla site and submitted a query on the query page.
8.  Dialog box popped up, saying "PermissiontoSetACookie".  Beneath it is a
checkbox for "Remember This Decision".  Beneath that are "No" and "Yes" buttons.
9.  Clicked "No" in the dialog box.  

Expected result:  dialog box disappears and I get my query results.
Actual result:  Identical box reappear.  I clicked "No" again for the second
time and the dialog box reappeared yet again.  I clicked "No" for the third
time.  The query results page loaded properly.

10.  Hit "Back" and submitted another query. 
11.  Clicked "Yes" in the dialog box without checking the "Remember This
Decision" checkbox.

Expected result:  dialog box disappears and I get my query results.  The next
time I perform a query again, it should ask me if I want to set a cookie again.
Actual results:  I have to click the "Yes" button three times to get pass this
dialog box and get to my query results page.  By the way, the dialog box that
popped up said "PermissiontoModifyCookie", and not "PermissiontoSetACookie".

My last comment is:  Did we intend to say "PermissiontoSetACookie?" and
"PermissiontoModifyCookie?" in the dialog box?  It doesn't seem very
user-friendly to me.

Pink/brade:  Not sure if these test results are what you intended.  Leaving as
Resolved Fixed for your commenting. 
(Assignee)

Comment 12

16 years ago
Winnie--without knowing the specifics of the web page (how many cookies are they
trying to set, etc?) I can't speak to specifics on expected behavior.  You
should probably confirm behavior against mozilla1.0 or 1.1a.  I do see that I am
prompted for 6 cookies (set or modify) with NS7.0PR1 when I go to Amazon.com
(regardless if I click Yes or No).  The dialogs might be "permission to set" or
"permission to modify" depending on what the site wants (and if the cookie is
already there).

By the way, it's a known issue that the strings you see in the dialog are NOT
the correct strings we should be displaying.  I will file a new bug on that
particular issue.
the strings should be fixed today, we found a workaround and filed some more
bugs. i can't imagine that we're doing anything different that moz wrt cookie
handling, i mean, all we're doing is showing the dialogs that the cookie service
wants.

Comment 14

16 years ago
verified 2002-07-01-05 - a dialog asking permission before setting cookies is
now popping up
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.